aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hans Johnson <hans.j.johnson@gmail.com>2019-11-17 15:14:25 -0600
committerGravatar Hans Johnson <hans.j.johnson@gmail.com>2019-11-17 15:14:25 -0600
commite78ed6e7f3d64f06761446d0a8dcb356a0373bff (patch)
tree13a446c077ed5477cc2a619ceac69b91c8e1f464 /CMakeLists.txt
parent9d5cdc98c3300662c112dd28a1c2a67c0389168d (diff)
COMP: Simplify install commands for Eigen
Confirm that install directory is identical before and after this simplifying patch. ```bash hg clone <<Eigen>> mkdir eigen-bld cd eigen-bld cmake ../Eigen -DCMAKE_INSTALL_PREFIX:PATH=/tmp/bef make install find /tmp/pre_eigen_modernize >/tmp/bef # Apply this patch cmake ../Eigen -DCMAKE_INSTALL_PREFIX:PATH=/tmp/aft make install find /tmp/post_eigen_modernize |sed 's/post_e/pre_e/g' >/tmp/aft diff /tmp/bef /tmp/aft ```
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c178ce56..619bd18f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -456,7 +456,7 @@ if(EIGEN_BUILD_PKGCONFIG)
)
endif()
-add_subdirectory(Eigen)
+install(DIRECTORY Eigen DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel)
add_subdirectory(doc EXCLUDE_FROM_ALL)