aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2010-10-23 10:00:43 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2010-10-23 10:00:43 -0400
commitca85a1f6c5fc33ac382aa2d7ba2da63d55d3223e (patch)
tree71909e5cf4cae13462115f0fb379bbd27ca84083 /CMakeLists.txt
parentdbdf7ee942c979a43a7082383e2a623e0b518176 (diff)
remove build type tweaking
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a52dfca24..dee8382df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,20 +81,6 @@ endif(NOT WIN32)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-string(TOLOWER "${CMAKE_BUILD_TYPE}" cmake_build_type_tolower)
-if(cmake_build_type_tolower STREQUAL "debug")
- set(CMAKE_BUILD_TYPE "Debug")
-elseif(cmake_build_type_tolower STREQUAL "release")
- set(CMAKE_BUILD_TYPE "Release")
-elseif(cmake_build_type_tolower STREQUAL "relwithdebinfo")
- set(CMAKE_BUILD_TYPE "RelWithDebInfo")
-elseif(cmake_build_type_tolower STREQUAL "")
- # Use 'Release' as default when build type is not specified
- set(CMAKE_BUILD_TYPE "Release")
-else()
- message(FATAL_ERROR "Unknown build type ${CMAKE_BUILD_TYPE}")
-endif()
-
string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile" AND NOT MSVC_IDE)
option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" ON)