aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jitse Niesen <jitse@maths.leeds.ac.uk>2010-10-22 12:23:35 +0100
committerGravatar Jitse Niesen <jitse@maths.leeds.ac.uk>2010-10-22 12:23:35 +0100
commitdbdf7ee942c979a43a7082383e2a623e0b518176 (patch)
treed5d691220509afe3510c7781032a9ffced33c185 /CMakeLists.txt
parentbfd46eacad8db3967c0c6ed51f3562fc27fe5a43 (diff)
Use 'Release' as default when build type is not specified.
Otherwise, "cmake /path/to/eigen/" in an empty build directory, as specified on the CMake page on the wiki, yields a fatal error.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f60dbd8fc..a52dfca24 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,9 @@ elseif(cmake_build_type_tolower STREQUAL "release")
set(CMAKE_BUILD_TYPE "Release")
elseif(cmake_build_type_tolower STREQUAL "relwithdebinfo")
set(CMAKE_BUILD_TYPE "RelWithDebInfo")
+elseif(cmake_build_type_tolower STREQUAL "")
+ # Use 'Release' as default when build type is not specified
+ set(CMAKE_BUILD_TYPE "Release")
else()
message(FATAL_ERROR "Unknown build type ${CMAKE_BUILD_TYPE}")
endif()