aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hauke Heibel <hauke.heibel@gmail.com>2010-10-21 07:39:06 +0200
committerGravatar Hauke Heibel <hauke.heibel@gmail.com>2010-10-21 07:39:06 +0200
commit9bbaff6b41a0fb432559ae0fec2fc30dfe327803 (patch)
treedda0da309913211522e241f9f783abd598982280 /CMakeLists.txt
parentee60fc2062636771770ddd3a56fbc6e700ae6266 (diff)
Fixed the unit test splitting for MSVC.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16f21faa5..869a78240 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,7 @@ else()
set(CMAKE_BUILD_TYPE "Release")
endif()
+string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile" AND NOT MSVC_IDE)
option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" ON)
else()
@@ -306,7 +307,6 @@ message("")
message("Configured Eigen ${EIGEN_VERSION_NUMBER}")
message("")
-string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile")
message("Some things you can do now:")
message("--------------+----------------------------------------------------------------")