aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hauke Heibel <hauke.heibel@gmail.com>2010-12-17 09:42:17 +0100
committerGravatar Hauke Heibel <hauke.heibel@gmail.com>2010-12-17 09:42:17 +0100
commit5e46f7a499d01765957a81135205d62798fb1f9e (patch)
tree7dfe4fd2a17957da7bad130e491e25749980babe /CMakeLists.txt
parenta21d56b7664d089f003ee98dd23383fd8d75ac68 (diff)
Switched back to the old behaviour where EIGEN_SPLIT_LARGE_TESTS was ON per default on MSVC systems.
Without splitting these tests, some do not compile
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 4 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee5f10c23..44b454e74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,12 +91,7 @@ endif(NOT WIN32)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
-if(cmake_generator_tolower MATCHES "makefile" AND NOT MSVC_IDE)
- option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" ON)
-else()
- option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" OFF)
-endif()
+option(EIGEN_SPLIT_LARGE_TESTS "Split large tests into smaller executables" ON)
option(EIGEN_DEFAULT_TO_ROW_MAJOR "Use row-major as default matrix storage order" OFF)
if(EIGEN_DEFAULT_TO_ROW_MAJOR)
@@ -296,9 +291,9 @@ add_subdirectory(demos EXCLUDE_FROM_ALL)
if(NOT MSVC)
if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(blas)
+ #add_subdirectory(blas)
else()
- add_subdirectory(blas EXCLUDE_FROM_ALL)
+ #add_subdirectory(blas EXCLUDE_FROM_ALL)
endif()
endif(NOT MSVC)
@@ -316,6 +311,7 @@ message("")
message("Configured Eigen ${EIGEN_VERSION_NUMBER}")
message("")
+string(TOLOWER "${CMAKE_GENERATOR}" cmake_generator_tolower)
if(cmake_generator_tolower MATCHES "makefile")
message("Some things you can do now:")
message("--------------+----------------------------------------------------------------")