aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2010-12-16 20:51:44 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2010-12-16 20:51:44 +0100
commita21d56b7664d089f003ee98dd23383fd8d75ac68 (patch)
tree02e5d2bfe2508682c5e75df61fea5f7d08d3083b /CMakeLists.txt
parentefdf2e405664163c685127aecec53a21977f8031 (diff)
disable blas if C++ compiler is MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8eee0a0eb..ee5f10c23 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -294,11 +294,13 @@ add_subdirectory(unsupported)
add_subdirectory(demos EXCLUDE_FROM_ALL)
+if(NOT MSVC)
if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
add_subdirectory(blas)
else()
add_subdirectory(blas EXCLUDE_FROM_ALL)
endif()
+endif(NOT MSVC)
# must be after test and unsupported, for configuring buildtests.in
add_subdirectory(scripts EXCLUDE_FROM_ALL)