summaryrefslogtreecommitdiff
path: root/xml
diff options
context:
space:
mode:
authorGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
committerGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
commit2b92a1c2d4fe890d0637402d3a2c542095197ede (patch)
tree857811d8786740be04a6d3fa73fdad22d51037f9 /xml
parentac4dd30829b4db1dbe3f8fc99cf90ee71cb2650f (diff)
xml/parse: Accept entity files on the command line
Signed-off-by: Anders Kaseorg <andersk@mit.edu> --- Makefile.am | 2 +- xml/parse.sml | 4 +--- 2 files changed, 2 insertions(+), 4 deletions(-)
Diffstat (limited to 'xml')
-rw-r--r--xml/parse.sml4
1 files changed, 1 insertions, 3 deletions
diff --git a/xml/parse.sml b/xml/parse.sml
index ad63c851..21256010 100644
--- a/xml/parse.sml
+++ b/xml/parse.sml
@@ -67,9 +67,7 @@ fun main () =
in
print "structure Entities = struct\n";
print "\tval all =\n";
- doFile "xml/xhtml-lat1.ent";
- doFile "xml/xhtml-special.ent";
- doFile "xml/xhtml-symbol.ent";
+ app doFile (CommandLine.arguments ());
print "\t[]\n";
print "end\n"
end