summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
committerGravatar Anders Kaseorg <andersk@mit.edu>2013-11-22 09:36:14 -0500
commit2b92a1c2d4fe890d0637402d3a2c542095197ede (patch)
tree857811d8786740be04a6d3fa73fdad22d51037f9
parentac4dd30829b4db1dbe3f8fc99cf90ee71cb2650f (diff)
xml/parse: Accept entity files on the command line
Signed-off-by: Anders Kaseorg <andersk@mit.edu> --- Makefile.am | 2 +- xml/parse.sml | 4 +--- 2 files changed, 2 insertions(+), 4 deletions(-)
-rw-r--r--Makefile.am2
-rw-r--r--xml/parse.sml4
2 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d88b08a9..fa3ee896 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,7 +63,7 @@ bin/urweb: xml/entities.sml \
$(MLTON) $(MLTONARGS) -output $@ src/compiler.mlb
xml/entities.sml: xml/parse xml/xhtml-lat1.ent xml/xhtml-special.ent xml/xhtml-symbol.ent
- xml/parse >xml/entities.sml
+ $^ > $@
xml/parse: xml/parse.sml
$(MLTON) $(MLTONARGS) xml/parse.sml
diff --git a/xml/parse.sml b/xml/parse.sml
index ad63c851..21256010 100644
--- a/xml/parse.sml
+++ b/xml/parse.sml
@@ -67,9 +67,7 @@ fun main () =
in
print "structure Entities = struct\n";
print "\tval all =\n";
- doFile "xml/xhtml-lat1.ent";
- doFile "xml/xhtml-special.ent";
- doFile "xml/xhtml-symbol.ent";
+ app doFile (CommandLine.arguments ());
print "\t[]\n";
print "end\n"
end