summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2016-11-07 17:31:19 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2016-11-07 17:31:19 -0500
commit4d37351eab0ea02ca065f4415aa6ac556a8c7820 (patch)
tree798a20febf7ee8dfe9bb8995f3cd4e0b3f074f4e /configure.ac
parentd5ae848de34109b66d2ec45fd6c0ac5a06149a68 (diff)
FastCGI: Track request IDs during processing
When processing a FastCGI request, save its request ID in thread-local storage and respond with the same request ID (rather than hard-coding 1). This fixes FastCGI on picky web servers (nginx). For more background, see https://github.com/urweb/urweb/issues/57 and ยง3.3 of the FastCGI specification. Tested with nginx 1.10.2 and lighttpd 1.4.39. Closes https://github.com/urweb/urweb/issues/57.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8ee3e795..0dda6d3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,7 @@ AC_PROG_LIBTOOL()
AC_CONFIG_HEADERS([include/urweb/config.h])
AX_PTHREAD([echo >/dev/null], [echo "Your C compiler does not support POSIX threads."; exit 1])
+AX_TLS([echo >/dev/null], [echo "Your C compiler does not support thread-local storage."; exit 1])
AX_CHECK_OPENSSL([echo >/dev/null], [echo "You must install OpenSSL development files."; exit 1])