summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2016-11-07 17:31:19 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2016-11-07 17:31:19 -0500
commit4d37351eab0ea02ca065f4415aa6ac556a8c7820 (patch)
tree798a20febf7ee8dfe9bb8995f3cd4e0b3f074f4e
parentd5ae848de34109b66d2ec45fd6c0ac5a06149a68 (diff)
FastCGI: Track request IDs during processing
When processing a FastCGI request, save its request ID in thread-local storage and respond with the same request ID (rather than hard-coding 1). This fixes FastCGI on picky web servers (nginx). For more background, see https://github.com/urweb/urweb/issues/57 and ยง3.3 of the FastCGI specification. Tested with nginx 1.10.2 and lighttpd 1.4.39. Closes https://github.com/urweb/urweb/issues/57.
-rw-r--r--configure.ac1
-rw-r--r--m4/ax_tls.m474
-rw-r--r--src/c/fastcgi.c45
3 files changed, 119 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8ee3e795..0dda6d3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,7 @@ AC_PROG_LIBTOOL()
AC_CONFIG_HEADERS([include/urweb/config.h])
AX_PTHREAD([echo >/dev/null], [echo "Your C compiler does not support POSIX threads."; exit 1])
+AX_TLS([echo >/dev/null], [echo "Your C compiler does not support thread-local storage."; exit 1])
AX_CHECK_OPENSSL([echo >/dev/null], [echo "You must install OpenSSL development files."; exit 1])
diff --git a/m4/ax_tls.m4 b/m4/ax_tls.m4
new file mode 100644
index 00000000..809b761a
--- /dev/null
+++ b/m4/ax_tls.m4
@@ -0,0 +1,74 @@
+# ===========================================================================
+# http://www.gnu.org/software/autoconf-archive/ax_tls.html
+# ===========================================================================
+#
+# SYNOPSIS
+#
+# AX_TLS([action-if-found], [action-if-not-found])
+#
+# DESCRIPTION
+#
+# Provides a test for the compiler support of thread local storage (TLS)
+# extensions. Defines TLS if it is found. Currently knows about GCC/ICC
+# and MSVC. I think SunPro uses the same as GCC, and Borland apparently
+# supports either.
+#
+# LICENSE
+#
+# Copyright (c) 2008 Alan Woodland <ajw05@aber.ac.uk>
+# Copyright (c) 2010 Diego Elio Petteno` <flameeyes@gmail.com>
+#
+# This program is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation, either version 3 of the License, or (at your
+# option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# As a special exception, the respective Autoconf Macro's copyright owner
+# gives unlimited permission to copy, distribute and modify the configure
+# scripts that are the output of Autoconf when processing the Macro. You
+# need not follow the terms of the GNU General Public License when using
+# or distributing such scripts, even though portions of the text of the
+# Macro appear in them. The GNU General Public License (GPL) does govern
+# all other use of the material that constitutes the Autoconf Macro.
+#
+# This special exception to the GPL applies to versions of the Autoconf
+# Macro released by the Autoconf Archive. When you make and distribute a
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
+#serial 11
+
+AC_DEFUN([AX_TLS], [
+ AC_MSG_CHECKING([for thread local storage (TLS) class])
+ AC_CACHE_VAL([ac_cv_tls],
+ [for ax_tls_keyword in __thread '__declspec(thread)' none; do
+ AS_CASE([$ax_tls_keyword],
+ [none], [ac_cv_tls=none ; break],
+ [AC_TRY_COMPILE(
+ [#include <stdlib.h>
+ static void
+ foo(void) {
+ static ] $ax_tls_keyword [ int bar;
+ exit(1);
+ }],
+ [],
+ [ac_cv_tls=$ax_tls_keyword ; break],
+ ac_cv_tls=none
+ )])
+ done
+ ])
+ AC_MSG_RESULT([$ac_cv_tls])
+
+ AS_IF([test "$ac_cv_tls" != "none"],
+ [AC_DEFINE_UNQUOTED([TLS],[$ac_cv_tls],[If the compiler supports a TLS storage class define it to that here])
+ m4_ifnblank([$1],[$1])],
+ [m4_ifnblank([$2],[$2])])
+])
diff --git a/src/c/fastcgi.c b/src/c/fastcgi.c
index cda3e1f6..c37debf7 100644
--- a/src/c/fastcgi.c
+++ b/src/c/fastcgi.c
@@ -1,5 +1,7 @@
#include "config.h"
+#include <assert.h>
+#include <stdint.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
@@ -20,6 +22,8 @@
#include "fastcgi.h"
+#define THREAD_LOCAL __thread
+
extern uw_app uw_application;
typedef struct {
@@ -44,6 +48,21 @@ typedef struct {
int available, used, sock;
} FCGI_Input;
+// The FastCGI request ID corresponding to the request being handled by the
+// current worker thread. (Each worker thread can only handle one request at a
+// time.)
+static THREAD_LOCAL int current_request_id;
+
+// Reads the FastCGI request ID from a FastCGI record. The result is guaranteed
+// to be in the range [0, 2^16); this function returns an int to avoid C type
+// promotion insanity.
+static int fastcgi_request_id(const FCGI_Record* const r) {
+ const int requestid = r->requestIdB1 << 8 | r->requestIdB0;
+ assert(requestid >= 0);
+ assert(requestid <= UINT16_MAX);
+ return requestid;
+}
+
static FCGI_Output *fastcgi_output() {
FCGI_Output *o = malloc(sizeof(FCGI_Output));
@@ -70,7 +89,9 @@ static int fastcgi_send(FCGI_Output *o,
unsigned char type,
unsigned short contentLength) {
o->r.type = type;
- o->r.requestIdB1 = o->r.requestIdB0 = 0;
+ assert(current_request_id <= UINT16_MAX);
+ o->r.requestIdB1 = current_request_id >> 8;
+ o->r.requestIdB0 = current_request_id & 0x000000ff;
o->r.contentLengthB1 = contentLength >> 8;
o->r.contentLengthB0 = contentLength & 255;
return uw_really_send(o->sock, &o->r, sizeof(o->r) - 65535 + contentLength);
@@ -356,6 +377,10 @@ static void *worker(void *data) {
goto done;
}
+ // Save the FastCGI request ID this worker is handling so that fastcgi_send
+ // can include it in its response.
+ current_request_id = fastcgi_request_id(r);
+
if (r->type != FCGI_BEGIN_REQUEST) {
write_stderr(out, "First message is not BEGIN_REQUEST\n");
goto done;
@@ -373,6 +398,15 @@ static void *worker(void *data) {
goto done;
}
+ if (fastcgi_request_id(r) != current_request_id) {
+ write_stderr(out,
+ "Ignoring environment variables for request %d (current"
+ " request has id %d)\n",
+ fastcgi_request_id(r),
+ current_request_id);
+ continue;
+ }
+
if (r->type != FCGI_PARAMS) {
write_stderr(out, "Expected FCGI_PARAMS but got %d\n", r->type);
goto done;
@@ -428,6 +462,15 @@ static void *worker(void *data) {
goto done;
}
+ if (fastcgi_request_id(r) != current_request_id) {
+ write_stderr(out,
+ "Ignoring STDIN for request %d (current request has id"
+ " %d)\n",
+ fastcgi_request_id(r),
+ current_request_id);
+ continue;
+ }
+
if (r->type != FCGI_STDIN) {
write_stderr(out, "Expected FCGI_STDIN but got %d\n", r->type);
goto done;