summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Marvin Sielenkemper <sielenk@gmx.de>2016-09-16 22:38:08 +0200
committerGravatar Marvin Sielenkemper <sielenk@gmx.de>2016-09-16 22:38:08 +0200
commit13a90684dc583427ad1d59a10d8bb00928fb6687 (patch)
tree30c465d49393d960694fb69f938c00d5cc3f20c0 /Makefile.am
parentc70444b4dd41960554f5f283d22e911df6447737 (diff)
Amend the tests to check if the new option works
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e945a47..3eb0a377 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -116,14 +116,14 @@ test:
bin/urweb -boot -noEmacs -dbms sqlite -db $(TESTDB) -demo /Demo demo
rm -f $(TESTDB)
sqlite3 $(TESTDB) < demo/demo.sql
- demo/demo.exe & echo $$! > $(TESTPID)
+ demo/demo.exe -a 127.0.0.1 & echo $$! > $(TESTPID)
sleep 1
(curl -s 'http://localhost:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false)
(curl -s 'http://localhost:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false)
kill `cat $(TESTPID)`
rm -f $(TESTDB)
sqlite3 $(TESTDB) < demo/demo.sql
- demo/demo.exe & echo $$! > $(TESTPID)
+ demo/demo.exe -A ::1 & echo $$! > $(TESTPID)
sleep 1
(curl -s 'http://[::1]:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false)
(curl -s 'http://[::1]:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false)