summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Marvin Sielenkemper <sielenk@gmx.de>2016-09-16 22:19:07 +0200
committerGravatar Marvin Sielenkemper <sielenk@gmx.de>2016-09-16 22:19:07 +0200
commitc70444b4dd41960554f5f283d22e911df6447737 (patch)
treef762a97665b517e28fcf0f4829e0910572480daa /Makefile.am
parent316befb960fea2009ed1b8bed26b4060f04673ba (diff)
Add tests for IPv6
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ab31acd..8e945a47 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -121,4 +121,11 @@ test:
(curl -s 'http://localhost:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false)
(curl -s 'http://localhost:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false)
kill `cat $(TESTPID)`
+ rm -f $(TESTDB)
+ sqlite3 $(TESTDB) < demo/demo.sql
+ demo/demo.exe & echo $$! > $(TESTPID)
+ sleep 1
+ (curl -s 'http://[::1]:8080/Demo/Hello/main' | diff tests/hello.html -) || (kill `cat $(TESTPID)`; echo "Test 'Hello' failed"; /bin/false)
+ (curl -s 'http://[::1]:8080/Demo/Crud1/create?A=1&B=2&C=3&D=4' | diff tests/crud1.html -) || (kill `cat $(TESTPID)`; echo "Test 'Crud1' failed"; /bin/false)
+ kill `cat $(TESTPID)`
echo Tests succeeded.