summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Chlipala <adamc@hcoop.net>2010-02-06 20:47:23 -0500
committerGravatar Adam Chlipala <adamc@hcoop.net>2010-02-06 20:47:23 -0500
commit97ebcb517f30f8f46f174aa9847f02a59a330adc (patch)
tree2aa12e67b820ee44300da665773b3efe254caa0d
parent9105d173c5d8fff3ed91c5b0a22642abfa2fbd90 (diff)
More fixes for NetBSD support
-rw-r--r--.hgignore2
-rw-r--r--Makefile.am8
-rw-r--r--Makefile.in8
-rw-r--r--src/c/cgi.c2
4 files changed, 11 insertions, 9 deletions
diff --git a/.hgignore b/.hgignore
index bcee8b16..cd7886cd 100644
--- a/.hgignore
+++ b/.hgignore
@@ -16,6 +16,8 @@ src/urweb.mlb
.libs
*.lo
*.la
+*.mlton.grm
+*.mlton.lex
src/config.sml
diff --git a/Makefile.am b/Makefile.am
index b5c19b79..ecb84ca0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,15 +33,15 @@ src/urweb.mlb: src/prefix.mlb src/sources src/suffix.mlb
| sed 's/^\(.*\).lex$$/\1.mlton.lex.sml/' \
>$@
-%.mlton.lex: %.lex
+src/urweb.mlton.lex: src/urweb.lex
cp $< $@
-%.mlton.grm: %.grm
+src/urweb.mlton.grm: src/urweb.grm
cp $< $@
-%.mlton.lex.sml: %.mlton.lex
+src/urweb.mlton.lex.sml: src/urweb.mlton.lex
mllex $<
-%.mlton.grm.sig %.mlton.grm.sml: %.mlton.grm
+src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml: src/urweb.mlton.grm
mlyacc $<
MLTON := mlton
diff --git a/Makefile.in b/Makefile.in
index 3d06747b..2f633e6c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -727,15 +727,15 @@ src/urweb.mlb: src/prefix.mlb src/sources src/suffix.mlb
| sed 's/^\(.*\).lex$$/\1.mlton.lex.sml/' \
>$@
-%.mlton.lex: %.lex
+src/urweb.mlton.lex: src/urweb.lex
cp $< $@
-%.mlton.grm: %.grm
+src/urweb.mlton.grm: src/urweb.grm
cp $< $@
-%.mlton.lex.sml: %.mlton.lex
+src/urweb.mlton.lex.sml: src/urweb.mlton.lex
mllex $<
-%.mlton.grm.sig %.mlton.grm.sml: %.mlton.grm
+src/urweb.mlton.grm.sig src/urweb.mlton.grm.sml: src/urweb.mlton.grm
mlyacc $<
#ifdef DEBUG
diff --git a/src/c/cgi.c b/src/c/cgi.c
index 98ad7479..e71b7e1c 100644
--- a/src/c/cgi.c
+++ b/src/c/cgi.c
@@ -25,7 +25,7 @@ static char *get_header(void *data, const char *h) {
strcpy(uppercased, "HTTP_");
for (s = uppercased+5; *h; ++h)
- *s++ = *h == '-' ? '_' : toupper(*h);
+ *s++ = *h == '-' ? '_' : toupper((int)*h);
*s = 0;
if ((r = getenv(uppercased)))