summaryrefslogtreecommitdiff
path: root/data
diff options
context:
space:
mode:
authorGravatar Patrick Griffis <tingping@tingping.se>2015-12-26 22:28:25 -0500
committerGravatar Patrick Griffis <tingping@tingping.se>2016-01-19 19:35:10 -0500
commitfaae3f026695ff28d92417880a0fd397adf5747e (patch)
tree1e65520802b2262307d784ff3430af157714313b /data
parent3f1418a0f987990b41fdb7b0a1f004fe03dea1eb (diff)
Move appdata to data and translate
Diffstat (limited to 'data')
-rw-r--r--data/Makefile.am7
-rw-r--r--data/transmission-remote-gtk.appdata.xml.in26
2 files changed, 32 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 50ece12..740e28e 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -5,4 +5,9 @@ desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
@DESKTOP_FILE_RULES@
-EXTRA_DIST = $(desktop_in_files)
+appdata_in_files = transmission-remote-gtk.appdata.xml.in
+appdata_XML = $(appdata_in_files:.xml.in=.xml)
+@INTLTOOL_XML_RULE@
+@APPSTREAM_XML_RULES@
+
+EXTRA_DIST = $(desktop_in_files) $(appdata_in_files)
diff --git a/data/transmission-remote-gtk.appdata.xml.in b/data/transmission-remote-gtk.appdata.xml.in
new file mode 100644
index 0000000..eebe9b2
--- /dev/null
+++ b/data/transmission-remote-gtk.appdata.xml.in
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright 2014 Alan F -->
+<application>
+ <id type="desktop">transmission-remote-gtk.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-2.0</project_license>
+ <name>Transmission Remote</name>
+ <summary>Remotely manage the Transmission BitTorrent client</summary>
+ <description>
+ <_p>
+ transmission-remote-gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
+ </_p>
+ <_p>Features</_p>
+ <ul>
+ <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents.</_li>
+ <_li>Works as a .torrent handler (eg. from a web browser).</_li>
+ <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers.</_li>
+ <_li>Change remote settings like global limits, download directory, and connectivity preferences.</_li>
+ </ul>
+ </description>
+ <screenshots>
+ <screenshot type="default" width="1024" height="576">http://eth0.org.uk/~alan/transmission-remote-gtk-1.1.1.png</screenshot>
+ </screenshots>
+ <url type="homepage">http://code.google.com/p/transmission-remote-gtk/</url>
+ <project_group>GNOME</project_group>
+</application>