summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac1
-rw-r--r--data/Makefile.am7
-rw-r--r--data/transmission-remote-gtk.appdata.xml.in (renamed from src/transmission-remote-gtk.appdata.xml)14
-rw-r--r--po/POTFILES.in1
-rw-r--r--src/Makefile.am7
5 files changed, 16 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 4d9606b..07e59df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,7 @@ LT_INIT
IT_PROG_INTLTOOL([0.50.1])
PKG_PROG_PKG_CONFIG([0.28])
DESKTOP_FILE
+APPSTREAM_XML
GETTEXT_PACKAGE=AC_PACKAGE_NAME
AC_SUBST(GETTEXT_PACKAGE)
diff --git a/data/Makefile.am b/data/Makefile.am
index 50ece12..740e28e 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -5,4 +5,9 @@ desktop_FILES = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
@DESKTOP_FILE_RULES@
-EXTRA_DIST = $(desktop_in_files)
+appdata_in_files = transmission-remote-gtk.appdata.xml.in
+appdata_XML = $(appdata_in_files:.xml.in=.xml)
+@INTLTOOL_XML_RULE@
+@APPSTREAM_XML_RULES@
+
+EXTRA_DIST = $(desktop_in_files) $(appdata_in_files)
diff --git a/src/transmission-remote-gtk.appdata.xml b/data/transmission-remote-gtk.appdata.xml.in
index f1333eb..eebe9b2 100644
--- a/src/transmission-remote-gtk.appdata.xml
+++ b/data/transmission-remote-gtk.appdata.xml.in
@@ -7,15 +7,15 @@
<name>Transmission Remote</name>
<summary>Remotely manage the Transmission BitTorrent client</summary>
<description>
- <p>
+ <_p>
transmission-remote-gtk allows you to remotely manage the Transmission BitTorrent client using its RPC interface.
- </p>
- <p>Features</p>
+ </_p>
+ <_p>Features</_p>
<ul>
- <li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents.</li>
- <li>Works as a .torrent handler (eg. from a web browser).</li>
- <li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers.</li>
- <li>Change remote settings like global limits, download directory, and connectivity preferences.</li>
+ <_li>Remotely add (file/url), start, stop, remove, remove and delete, verify, reannounce torrents.</_li>
+ <_li>Works as a .torrent handler (eg. from a web browser).</_li>
+ <_li>Set torrent properties such as speed, seed, peer limits, file priorities, add/edit/remove trackers.</_li>
+ <_li>Change remote settings like global limits, download directory, and connectivity preferences.</_li>
</ul>
</description>
<screenshots>
diff --git a/po/POTFILES.in b/po/POTFILES.in
index 6bd2a6e..8440abd 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,4 +1,5 @@
[type: gettext/ini]data/transmission-remote-gtk.desktop.in
+[type: gettext/xml]data/transmission-remote-gtk.appdata.xml.in
src/bencode.c
src/hig.c
src/json.c
diff --git a/src/Makefile.am b/src/Makefile.am
index 43306fa..e8647ab 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,15 +18,10 @@
#
if !WIN32
-EXTRA_DIST = transmission-remote-gtk.pod transmission-remote-gtk.appdata.xml
+EXTRA_DIST = transmission-remote-gtk.pod
CLEANFILES = transmission-remote-gtk.1
man_MANS = transmission-remote-gtk.1
-
-
-
-appdatadir = $(datadir)/appdata
-appdata_DATA = transmission-remote-gtk.appdata.xml
endif
bin_PROGRAMS = transmission-remote-gtk