summaryrefslogtreecommitdiff
path: root/DEVELOPERS.md
diff options
context:
space:
mode:
Diffstat (limited to 'DEVELOPERS.md')
-rw-r--r--DEVELOPERS.md17
1 files changed, 17 insertions, 0 deletions
diff --git a/DEVELOPERS.md b/DEVELOPERS.md
index 0253a7f..55dad80 100644
--- a/DEVELOPERS.md
+++ b/DEVELOPERS.md
@@ -11,3 +11,20 @@ and `**/Makefile.am`), run these commands:
aclocal && \
automake --add-missing --copy && \
autoconf
+
+Debian
+------
+
+First, everything must be set up just right:
+
+ mkdir -p ~/debian/rcm && \
+ cp -a rcm ~/debian/rcm/rcm-0.0.2 && \
+ cd ~/debian/rcm && \
+ rm -f rcm_0.0.2.orig.tar.gz && \
+ rm -f rcm-0.0.2/tags && \
+ tar --exclude=*swp --exclude-backups --exclude-vcs --exclude=debian -zcf rcm_0.0.2.orig.tar.gz rcm-0.0.2
+
+Given that, now you can generate the Debian package:
+
+ cd ~/debian/rcm/rcm-0.0.2 && \
+ debuild -us -uc