summaryrefslogtreecommitdiff
path: root/DEVELOPERS.md
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2013-07-27 01:19:54 -0400
committerGravatar Mike Burns <mike@mike-burns.com>2013-07-27 20:07:50 -0400
commit74367c4d887c672a2cf5106107d074279828858c (patch)
treeeca84f3358782e68bb1b433753255500c333c3ef /DEVELOPERS.md
parent4f5259cc5b6273f509602434747f702d16b71b27 (diff)
Able to generate deb packages
The following command can generate a Debian package: debuild -us uc The directory structure and tarball must be perfectly set up first. This is documented in `DEVELOPERS.md`.
Diffstat (limited to 'DEVELOPERS.md')
-rw-r--r--DEVELOPERS.md17
1 files changed, 17 insertions, 0 deletions
diff --git a/DEVELOPERS.md b/DEVELOPERS.md
index 0253a7f..55dad80 100644
--- a/DEVELOPERS.md
+++ b/DEVELOPERS.md
@@ -11,3 +11,20 @@ and `**/Makefile.am`), run these commands:
aclocal && \
automake --add-missing --copy && \
autoconf
+
+Debian
+------
+
+First, everything must be set up just right:
+
+ mkdir -p ~/debian/rcm && \
+ cp -a rcm ~/debian/rcm/rcm-0.0.2 && \
+ cd ~/debian/rcm && \
+ rm -f rcm_0.0.2.orig.tar.gz && \
+ rm -f rcm-0.0.2/tags && \
+ tar --exclude=*swp --exclude-backups --exclude-vcs --exclude=debian -zcf rcm_0.0.2.orig.tar.gz rcm-0.0.2
+
+Given that, now you can generate the Debian package:
+
+ cd ~/debian/rcm/rcm-0.0.2 && \
+ debuild -us -uc