summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2013-07-27 01:19:54 -0400
committerGravatar Mike Burns <mike@mike-burns.com>2013-07-27 20:07:50 -0400
commit74367c4d887c672a2cf5106107d074279828858c (patch)
treeeca84f3358782e68bb1b433753255500c333c3ef /debian/rules
parent4f5259cc5b6273f509602434747f702d16b71b27 (diff)
Able to generate deb packages
The following command can generate a Debian package: debuild -us uc The directory structure and tarball must be perfectly set up first. This is documented in `DEVELOPERS.md`.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c259a57
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+
+%:
+ dh $@