summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Mike Burns <mike@mike-burns.com>2013-07-27 01:19:54 -0400
committerGravatar Mike Burns <mike@mike-burns.com>2013-07-27 20:07:50 -0400
commit74367c4d887c672a2cf5106107d074279828858c (patch)
treeeca84f3358782e68bb1b433753255500c333c3ef /debian
parent4f5259cc5b6273f509602434747f702d16b71b27 (diff)
Able to generate deb packages
The following command can generate a Debian package: debuild -us uc The directory structure and tarball must be perfectly set up first. This is documented in `DEVELOPERS.md`.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control19
-rw-r--r--debian/copyright30
-rw-r--r--debian/docs1
-rw-r--r--debian/files1
-rw-r--r--debian/rcm.substvars1
-rwxr-xr-xdebian/rules21
-rw-r--r--debian/source/format1
9 files changed, 80 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..c06838b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+rcm (0.0.2-1) unstable; urgency=low
+
+ * Initial Debian release (Closes: #1)
+
+ -- Mike Burns <mburns@thoughtbot.com> Tue, 23 Jul 2013 16:43:33 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..45a4fb7
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+8
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..02f1b10
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,19 @@
+Source: rcm
+Section: utils
+Priority: extra
+Maintainer: Mike Burns <mburns@thoughtbot.com>
+Build-Depends: debhelper (>= 8.0.0)
+Standards-Version: 3.9.3
+Homepage: http://github.com/mike-burns/rcm
+Vcs-Git: git://github.com/mike-burns/rcm.git
+Vcs-Browser: http://github.com/mike-burns/rcm
+
+Package: rcm
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: management suite for dotfiles
+ You have dotfiles. Maybe you have them in a repo that you share; maybe you
+ have them in a privately-backed up directory; or maybe you just have them
+ scattered about your homedir. Regardless, this package provides a suite of
+ programs that will help manage an existing dotfiles collection and also start
+ a new one.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..3fa949f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,30 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: rcm
+Source: git@github.com:mike-burns/rcm.git
+
+Files: *
+Copyright: 2013 Mike Burns <mburns@thoughtbot.com>
+License: BSD-3
+ All rights reserved.
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are
+ met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of Mike Burns nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+ IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+ TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+ PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+ TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+ PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..b43bf86
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..39ac931
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+rcm_0.0.2-1_all.deb utils extra
diff --git a/debian/rcm.substvars b/debian/rcm.substvars
new file mode 100644
index 0000000..abd3ebe
--- /dev/null
+++ b/debian/rcm.substvars
@@ -0,0 +1 @@
+misc:Depends=
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c259a57
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)