summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am5
-rw-r--r--configure.in9
-rw-r--r--moduleconf.h1
-rw-r--r--plugins/mpgmad/Makefile.am7
-rw-r--r--plugins/mpgmad/mpgmad.c (renamed from cmp3.c)6
5 files changed, 21 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 3172b77b..b326e531 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,8 @@ SUBDIRS = gme/Game_Music_Emu-0.5.2\
plugins/hotkeys\
plugins/lastfm\
${APE_DIR}\
- plugins/demac
+ plugins/demac\
+ ${MPGMAD_DIR}
dumbpath=@top_srcdir@/dumb
sidpath=@top_srcdir@/sid/sidplay-libs-2.1.0
@@ -28,7 +29,7 @@ deadbeef_SOURCES =\
messagepump.c messagepump.h messages.h\
conf.c conf.h\
search.c search.h\
- cmp3.c cvorbis.c cflac.c cgme.c cdumb.c csid.cpp\
+ cvorbis.c cflac.c cgme.c cdumb.c csid.cpp\
palsa.c palsa.h playback.h\
threading_pthread.c threading.h\
md5/md5.c md5/md5.h md5/md5_loc.h\
diff --git a/configure.in b/configure.in
index f1a47902..3e23002f 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ AC_DEFINE_UNQUOTED(PREFIX, "${prefix}")
CFLAGS="$CFLAGS -D_GNU_SOURCE -O2 -DHAVE_UNIX"
CPPFLAGS="$CFLAGS"
-PKG_CHECK_MODULES(DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0 vorbis vorbisfile mad samplerate alsa)
+PKG_CHECK_MODULES(DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0 vorbis vorbisfile samplerate alsa)
PKG_CHECK_MODULES(LASTFM_DEPS, libcurl)
AX_EXT()
@@ -39,6 +39,12 @@ AC_SUBST(HAVE_LIBMAC)
AC_SUBST(APE_LIBS)
AC_SUBST(APE_DIR)
+dnl mpgmad plugin
+AC_CHECK_LIB([mad], [main], [HAVE_LIBMAD=1 ; MAD_DEPS_LIBS="-lmad" ; MPGMAD_DIR="plugins/mpgmad"])
+AC_SUBST(HAVE_LIBMAD)
+AC_SUBST(MAD_DEPS_LIBS)
+AC_SUBST(MPGMAD_DIR)
+
AC_OUTPUT([
Makefile
pixmaps/Makefile
@@ -50,6 +56,7 @@ plugins/hotkeys/Makefile
plugins/lastfm/Makefile
plugins/ape/Makefile
plugins/demac/Makefile
+plugins/mpgmad/Makefile
deadbeef.desktop
])
diff --git a/moduleconf.h b/moduleconf.h
index 5a73da1b..795187ed 100644
--- a/moduleconf.h
+++ b/moduleconf.h
@@ -1,4 +1,3 @@
-PLUG(mpegmad)
PLUG(oggvorbis)
PLUG(flac)
PLUG(gme)
diff --git a/plugins/mpgmad/Makefile.am b/plugins/mpgmad/Makefile.am
new file mode 100644
index 00000000..9902cc0e
--- /dev/null
+++ b/plugins/mpgmad/Makefile.am
@@ -0,0 +1,7 @@
+mpgmaddir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = mpgmad.la
+mpgmad_la_SOURCES = mpgmad.c
+mpgmad_la_LDFLAGS = -module
+
+mpgmad_la_LIBADD = $(LDADD) $(MAD_DEPS_LIBS)
+AM_CFLAGS = $(MAD_DEPS_CFLAGS) -std=c99
diff --git a/cmp3.c b/plugins/mpgmad/mpgmad.c
index 4b5c6178..b4f71906 100644
--- a/cmp3.c
+++ b/plugins/mpgmad/mpgmad.c
@@ -998,7 +998,7 @@ static DB_decoder_t plugin = {
.plugin.version_major = 0,
.plugin.version_minor = 1,
.plugin.type = DB_PLUGIN_DECODER,
- .plugin.name = "MPEG 1/2/3 decoder",
+ .plugin.name = "MPEG v1,2 layer1,2,3 decoder",
.plugin.descr = "based on libmad",
.plugin.author = "Alexey Yakovenko",
.plugin.email = "waker@users.sourceforge.net",
@@ -1011,12 +1011,12 @@ static DB_decoder_t plugin = {
.seek = cmp3_seek,
.insert = cmp3_insert,
.exts = exts,
- .id = "stdmp3",
+ .id = "stdmpg",
.filetypes = filetypes
};
DB_plugin_t *
-mpegmad_load (DB_functions_t *api) {
+mpgmad_load (DB_functions_t *api) {
deadbeef = api;
return DB_PLUGIN (&plugin);
}