summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac2
-rw-r--r--deadbeef.h10
-rw-r--r--plugins/adplug/Makefile.am2
-rw-r--r--plugins/gtkui/gtkui.c5
5 files changed, 5 insertions, 16 deletions
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index a2906f35..996f8e46 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-0.6.0-beta5
+0.6.0-beta6
diff --git a/configure.ac b/configure.ac
index 7b63603a..0a3e2050 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,7 +247,7 @@ AC_SUBST(COREAUDIO_LIBS)
AS_IF([test "${enable_ffmpeg}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
FFMPEG_DEPS_CFLAGS="-I../../$LIB/include"
- FFMPEG_DEPS_LIBS="../../$LIB/lib/libavcodec.a -lpthread ../../$LIB/lib/libavformat.a ../../$LIB/lib/libavcodec.a ../../$LIB/lib/libavutil.a ../../$LIB/lib/libavcore.a -lm ../../$LIB/lib/libz.a"
+ FFMPEG_DEPS_LIBS="../../$LIB/lib/libavcodec.a -lpthread ../../$LIB/lib/libavformat.a ../../$LIB/lib/libavcodec.a ../../$LIB/lib/libavutil.a -lm ../../$LIB/lib/libz.a ../../$LIB/lib/libopencore-amrnb.a ../../$LIB/lib/libopencore-amrwb.a ../../$LIB/lib/libopus.a"
AC_SUBST(FFMPEG_DEPS_CFLAGS)
AC_SUBST(FFMPEG_DEPS_LIBS)
HAVE_FFMPEG=yes
diff --git a/deadbeef.h b/deadbeef.h
index e5ab6756..1baf7bca 100644
--- a/deadbeef.h
+++ b/deadbeef.h
@@ -876,17 +876,7 @@ typedef struct DB_plugin_action_s {
const char *title;
const char *name;
uint32_t flags;
- /**
- * Function called when user activates menu item
- * @action pointer to action struct itself
- * @it pointer to selected playitem for single-track action,
- * to first playitem for multiple-track action,
- * or NULL for common action
- * @returns unused
- */
DB_plugin_action_callback_t callback;
-
- //we have linked list here
struct DB_plugin_action_s *next;
} DB_plugin_action_t;
diff --git a/plugins/adplug/Makefile.am b/plugins/adplug/Makefile.am
index 471cb3cd..398f23ca 100644
--- a/plugins/adplug/Makefile.am
+++ b/plugins/adplug/Makefile.am
@@ -5,7 +5,7 @@ adlibdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = adplug.la
AM_CFLAGS = $(CFLAGS) -std=c99 -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fPIC
-adplug_la_LDFLAGS = -module -lm $(NOCPPLIB)
+adplug_la_LDFLAGS = -module $(NOCPPLIB) -lm
AM_CPPFLAGS = $(CXXFLAGS) -Dstricmp=strcasecmp -DVERSION=\"2.1\" -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fno-exceptions -fno-rtti -fno-unwind-tables
diff --git a/plugins/gtkui/gtkui.c b/plugins/gtkui/gtkui.c
index d08527b3..a590d51d 100644
--- a/plugins/gtkui/gtkui.c
+++ b/plugins/gtkui/gtkui.c
@@ -1683,11 +1683,10 @@ static ddb_gtkui_t plugin = {
"You should have received a copy of the GNU General Public License\n"
"along with this program; if not, write to the Free Software\n"
"Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.\n"
-#if GTK_CHECK_VERSION(3,0,0)
"\n"
- "This plugin includes GTK3 port of gtkglext from https://github.com/tdz/gtkglext\n"
+ "This plugin includes gtkglext-1.0.2\n"
+ "GTK3 version uses the unofficial port from https://github.com/tdz/gtkglext\n"
"(C) gtkglext authors and contributors under LGPLv2.1\n"
-#endif
,
.gui.plugin.website = "http://deadbeef.sf.net",
.gui.plugin.start = gtkui_start,