summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac4
-rw-r--r--plugins/vorbis/Makefile.am2
3 files changed, 5 insertions, 3 deletions
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index ee6cdce3..d64531f1 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-0.6.1
+devel
diff --git a/configure.ac b/configure.ac
index 7695f889..a36f2a70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [0.6.1])
+AC_INIT([deadbeef], [devel])
AC_CONFIG_HEADER(config.h)
@@ -322,7 +322,9 @@ AS_IF([test "${enable_vorbis}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_VORBISPLUGIN=yes
VORBIS_LIBS="../../$LIB/lib/libogg.a ../../$LIB/lib/libvorbis.a ../../$LIB/lib/libvorbisenc.a ../../$LIB/lib/libvorbisfile.a"
+ VORBIS_CFLAGS="-I../../$LIB/include"
AC_SUBST(VORBIS_LIBS)
+ AC_SUBST(VORBIS_CFLAGS)
], [
AC_CHECK_LIB([vorbis], [main], [HAVE_VORBIS=yes])
AC_CHECK_LIB([vorbisfile], [main], [HAVE_VORBISFILE=yes])
diff --git a/plugins/vorbis/Makefile.am b/plugins/vorbis/Makefile.am
index 8587e54a..f1beef70 100644
--- a/plugins/vorbis/Makefile.am
+++ b/plugins/vorbis/Makefile.am
@@ -5,5 +5,5 @@ vorbis_la_SOURCES = vorbis.c vcedit.c vcedit.h vceditaux.h i18n.h
vorbis_la_LDFLAGS = -module -lm
vorbis_la_LIBADD = $(LDADD) $(VORBIS_LIBS)
-AM_CFLAGS = $(CFLAGS) -std=c99
+AM_CFLAGS = $(CFLAGS) $(VORBIS_CFLAGS) -std=c99
endif