summaryrefslogtreecommitdiff
path: root/scripts/portable_package_static.sh
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-05 17:46:33 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-05 17:46:33 +0200
commitce2923c8f0cac7a563d1ecf22085ac62281c74d7 (patch)
tree20ce1a2fd0cebc36231882b011e34230778a1db9 /scripts/portable_package_static.sh
parent527ba48d8209a8e854c791d571106a5daf2fdd29 (diff)
parent708c8ba9f7aefe9f795c9c4eb30ab128f09c8b3d (diff)
Merge branch 'master' into devel
Conflicts: README configure.ac deadbeef.h plugins.c plugins/gtkui/Makefile.am plugins/gtkui/ddbcellrenderertextmultiline.c plugins/gtkui/ddblistview.c plugins/gtkui/deadbeef.glade plugins/gtkui/gtkui.c plugins/gtkui/interface.c plugins/gtkui/plcommon.c plugins/shellexec/shellexec.c plugins/supereq/Makefile.am
Diffstat (limited to 'scripts/portable_package_static.sh')
-rwxr-xr-xscripts/portable_package_static.sh18
1 files changed, 13 insertions, 5 deletions
diff --git a/scripts/portable_package_static.sh b/scripts/portable_package_static.sh
index 2b8e5465..1ad0c076 100755
--- a/scripts/portable_package_static.sh
+++ b/scripts/portable_package_static.sh
@@ -1,21 +1,28 @@
#!/bin/sh
+./scripts/portable_postbuild.sh
+
# package for distribution
VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
BUILD=`cat PORTABLE_BUILD | perl -ne 'chomp and print'`
+ARCH=`uname -m | perl -ne 'chomp and print'`
# main distro
SRCDIR=deadbeef-$VERSION
PLUGDIR=$SRCDIR/plugins
DOCDIR=$SRCDIR/doc
PIXMAPDIR=$SRCDIR/pixmaps
+OUTNAME=deadbeef-static_${VERSION}-${BUILD}_${ARCH}.tar.bz2
+
+ARCH=`uname -m | perl -ne 'chomp and print'`
-rm portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2
+rm portable_out/build/$OUTNAME
-cd portable
-tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
+cd portable/$ARCH
+tar jcvf ../../portable_out/build/$OUTNAME\
$SRCDIR/deadbeef\
$SRCDIR/deadbeef.png\
+ $SRCDIR/.ddb_portable\
$DOCDIR\
$PLUGDIR/aac.so\
$PLUGDIR/adplug.so\
@@ -39,6 +46,7 @@ tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
$PLUGDIR/nullout.so\
$PLUGDIR/oss.so\
$PLUGDIR/shellexec.so\
+ $PLUGDIR/shellexecui_gtk2.so\
$PLUGDIR/sid.so\
$PLUGDIR/sndfile.so\
$PLUGDIR/supereq.so\
@@ -57,7 +65,7 @@ tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
$PLUGDIR/convpresets\
$PLUGDIR/pulse.so\
$PLUGDIR/dsp_libsrc.so\
- $PLUGDIR/mono2stereo.so\
+ $PLUGDIR/ddb_mono2stereo.so\
$PIXMAPDIR\
$SRCDIR/locale
-cd ..
+cd ../..