summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-05 17:46:33 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-05 17:46:33 +0200
commitce2923c8f0cac7a563d1ecf22085ac62281c74d7 (patch)
tree20ce1a2fd0cebc36231882b011e34230778a1db9 /scripts
parent527ba48d8209a8e854c791d571106a5daf2fdd29 (diff)
parent708c8ba9f7aefe9f795c9c4eb30ab128f09c8b3d (diff)
Merge branch 'master' into devel
Conflicts: README configure.ac deadbeef.h plugins.c plugins/gtkui/Makefile.am plugins/gtkui/ddbcellrenderertextmultiline.c plugins/gtkui/ddblistview.c plugins/gtkui/deadbeef.glade plugins/gtkui/gtkui.c plugins/gtkui/interface.c plugins/gtkui/plcommon.c plugins/shellexec/shellexec.c plugins/supereq/Makefile.am
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/portable_build.sh9
-rwxr-xr-xscripts/portable_package_static.sh18
-rwxr-xr-xscripts/portable_postbuild.sh9
-rwxr-xr-xscripts/quickinstall.sh5
-rwxr-xr-xscripts/static_build.sh22
-rwxr-xr-xscripts/static_install.sh4
6 files changed, 53 insertions, 14 deletions
diff --git a/scripts/portable_build.sh b/scripts/portable_build.sh
index 6a047023..3a11ea99 100755
--- a/scripts/portable_build.sh
+++ b/scripts/portable_build.sh
@@ -1,9 +1,10 @@
#!/bin/sh
VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
ORIGIN=`pwd | perl -ne 'chomp and print'`
-AP=$HOME/bin/autopackage
-export CC=$AP/apbuild/apgcc
-export CXX=$AP/apbuild/apgcc
+AP=$ORIGIN/tools/apbuild
+export CC=$AP/apgcc
+export CXX=$AP/apgcc
+
export APBUILD_STATIC_LIBGCC=1
./autogen.sh
@@ -22,5 +23,3 @@ cd tools/pluginfo
make
cd ../../
-./scripts/portable_postbuild.sh
-
diff --git a/scripts/portable_package_static.sh b/scripts/portable_package_static.sh
index 2b8e5465..1ad0c076 100755
--- a/scripts/portable_package_static.sh
+++ b/scripts/portable_package_static.sh
@@ -1,21 +1,28 @@
#!/bin/sh
+./scripts/portable_postbuild.sh
+
# package for distribution
VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
BUILD=`cat PORTABLE_BUILD | perl -ne 'chomp and print'`
+ARCH=`uname -m | perl -ne 'chomp and print'`
# main distro
SRCDIR=deadbeef-$VERSION
PLUGDIR=$SRCDIR/plugins
DOCDIR=$SRCDIR/doc
PIXMAPDIR=$SRCDIR/pixmaps
+OUTNAME=deadbeef-static_${VERSION}-${BUILD}_${ARCH}.tar.bz2
+
+ARCH=`uname -m | perl -ne 'chomp and print'`
-rm portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2
+rm portable_out/build/$OUTNAME
-cd portable
-tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
+cd portable/$ARCH
+tar jcvf ../../portable_out/build/$OUTNAME\
$SRCDIR/deadbeef\
$SRCDIR/deadbeef.png\
+ $SRCDIR/.ddb_portable\
$DOCDIR\
$PLUGDIR/aac.so\
$PLUGDIR/adplug.so\
@@ -39,6 +46,7 @@ tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
$PLUGDIR/nullout.so\
$PLUGDIR/oss.so\
$PLUGDIR/shellexec.so\
+ $PLUGDIR/shellexecui_gtk2.so\
$PLUGDIR/sid.so\
$PLUGDIR/sndfile.so\
$PLUGDIR/supereq.so\
@@ -57,7 +65,7 @@ tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
$PLUGDIR/convpresets\
$PLUGDIR/pulse.so\
$PLUGDIR/dsp_libsrc.so\
- $PLUGDIR/mono2stereo.so\
+ $PLUGDIR/ddb_mono2stereo.so\
$PIXMAPDIR\
$SRCDIR/locale
-cd ..
+cd ../..
diff --git a/scripts/portable_postbuild.sh b/scripts/portable_postbuild.sh
index f572240f..45db6740 100755
--- a/scripts/portable_postbuild.sh
+++ b/scripts/portable_postbuild.sh
@@ -1,10 +1,12 @@
#!/bin/sh
VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
OSTYPE=`uname -s`
-OUTDIR=portable/deadbeef-$VERSION
+ARCH=`uname -m | perl -ne 'chomp and print'`
+OUTDIR=portable/$ARCH/deadbeef-$VERSION
PLUGDIR=$OUTDIR/plugins
DOCDIR=$OUTDIR/doc
PIXMAPDIR=$OUTDIR/pixmaps
+echo OUTDIR=$OUTDIR
rm -rf $OUTDIR
@@ -18,7 +20,7 @@ for i in nullout cdda flac alsa mpgmad hotkeys vtx \
ffap ffmpeg wavpack vorbis oss vfs_curl \
lastfm sid adplug sndfile artwork \
supereq gme dumb notify musepack wildmidi \
- tta dca aac mms shn ao shellexec vfs_zip \
+ tta dca aac mms shn ao shellexec shellexecui vfs_zip \
m3u converter pulse dsp_libsrc mono2stereo ; do
if [ -f ./plugins/$i/.libs/$i.so ]; then
cp ./plugins/$i/.libs/$i.so $PLUGDIR/
@@ -53,7 +55,7 @@ fi
#pixmaps
-for i in pause_16.png play_16.png noartwork.jpg buffering_16.png; do
+for i in pause_16.png play_16.png noartwork.png buffering_16.png; do
cp ./pixmaps/$i $PIXMAPDIR/
done
@@ -77,6 +79,7 @@ for i in po/*.gmo ; do
done
cp translation/help.pt_BR.txt $OUTDIR/doc/
cp translation/help.ru.txt $OUTDIR/doc/
+touch $OUTDIR/.ddb_portable
# strip
if [ $OSTYPE != 'Darwin' ];then
diff --git a/scripts/quickinstall.sh b/scripts/quickinstall.sh
index 38f1ac7e..41cc412e 100755
--- a/scripts/quickinstall.sh
+++ b/scripts/quickinstall.sh
@@ -33,8 +33,10 @@ cp ./plugins/dca/.libs/dca.so /usr/local/lib/deadbeef/
cp ./plugins/aac/.libs/aac.so /usr/local/lib/deadbeef/
cp ./plugins/mms/.libs/mms.so /usr/local/lib/deadbeef/
cp ./plugins/shn/.libs/ddb_shn.so /usr/local/lib/deadbeef/
-cp ./plugins/ao/.libs/ddb_aopsf.so /usr/local/lib/deadbeef/
+cp ./plugins/ao/.libs/ddb_ao.so /usr/local/lib/deadbeef/
cp ./plugins/shellexec/.libs/shellexec.so /usr/local/lib/deadbeef/
+cp ./plugins/shellexecui/.libs/shellexecui_gtk2.so /usr/local/lib/deadbeef/
+cp ./plugins/shellexecui/.libs/shellexecui_gtk3.so /usr/local/lib/deadbeef/
cp ./plugins/dsp_libsrc/.libs/dsp_libsrc.so /usr/local/lib/deadbeef/
cp ./plugins/m3u/.libs/m3u.so /usr/local/lib/deadbeef/
cp ./plugins/ddb_input_uade2/ddb_input_uade2.so /usr/local/lib/deadbeef/
@@ -45,3 +47,4 @@ cp ./plugins/soundtouch/ddb_soundtouch.so /usr/local/lib/deadbeef/
cp ./plugins/vfs_zip/.libs/vfs_zip.so /usr/local/lib/deadbeef/
cp ./plugins/medialib/.libs/medialib.so /usr/local/lib/deadbeef/
cp ./plugins/mono2stereo/.libs/ddb_mono2stereo.so /usr/local/lib/deadbeef/
+cp ./plugins/alac/.libs/alac.so /usr/local/lib/deadbeef/
diff --git a/scripts/static_build.sh b/scripts/static_build.sh
new file mode 100755
index 00000000..250b29e8
--- /dev/null
+++ b/scripts/static_build.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
+ORIGIN=`pwd | perl -ne 'chomp and print'`
+AP=$ORIGIN/tools/apbuild
+ARCH=`uname -m | perl -ne 'chomp and print'`
+
+cd tools/apbuild
+./apinit
+cd ../../
+
+./autogen.sh
+
+export APBUILD_STATIC_LIBGCC=1
+CC=$AP/apgcc CXX=$AP/apgcc ./configure --enable-staticlink --disable-artwork-imlib2 --prefix=/opt/deadbeef
+sed -i 's/-lstdc++ -lm -lgcc_s -lc -lgcc_s/-lm -lc/g' libtool
+make clean
+make DESTDIR=`pwd`/static/$ARCH/deadbeef-$VERSION -j8 install
+
+echo "building pluginfo tool..."
+cd tools/pluginfo
+make
+cd ../../
diff --git a/scripts/static_install.sh b/scripts/static_install.sh
new file mode 100755
index 00000000..d2295961
--- /dev/null
+++ b/scripts/static_install.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
+ARCH=`uname -m | perl -ne 'chomp and print'`
+DESTDIR=`pwd`/static/$ARCH/deadbeef-$VERSION make install