summaryrefslogtreecommitdiff
path: root/plugins
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-07 20:48:50 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-07 20:48:50 +0200
commitb7b34c23144af9147bc6878e48b3957232174655 (patch)
tree95030d983627a1de977dce5d9836a0f38d3703f0 /plugins
parent61c87258bb9411046ffd7223437923e683ce020c (diff)
wiped libmac ape support (libmac has critical bug in seeking code)
Diffstat (limited to 'plugins')
-rw-r--r--plugins/ape/Makefile.am2
-rw-r--r--plugins/ape/ape.c3
2 files changed, 2 insertions, 3 deletions
diff --git a/plugins/ape/Makefile.am b/plugins/ape/Makefile.am
index f36df197..d5678f4f 100644
--- a/plugins/ape/Makefile.am
+++ b/plugins/ape/Makefile.am
@@ -4,4 +4,4 @@ ape_la_SOURCES = ape.c apewrapper.cpp apewrapper.h
ape_la_LDFLAGS = -module
ape_la_LIBADD = $(LDADD) $(APE_LIBS)
-AM_CFLAGS = $(CFLAGS) -std=c99
+AM_CFLAGS = $(CFLAGS) -std=c99 -O0 -g
diff --git a/plugins/ape/ape.c b/plugins/ape/ape.c
index 4064666e..9443dfa2 100644
--- a/plugins/ape/ape.c
+++ b/plugins/ape/ape.c
@@ -90,7 +90,6 @@ ape_init (DB_playItem_t *it) {
neg = 1<<plugin.info.bps;
sign = (1<<31);
signshift = plugin.info.bps-1;
-
return 0;
}
@@ -178,13 +177,13 @@ ape_seek (float seconds) {
samplesdecoded = nblock;
ape_blocks_left = ape_total_blocks - nblock;
plugin.info.readpos = samplesdecoded / (float)plugin.info.samplerate - timestart;
+ return 0;
}
static DB_playItem_t *
ape_insert (DB_playItem_t *after, const char *fname) {
void *dec = ape_decompress_create (fname);
if (!dec) {
- ape_decompress_destroy (dec);
return NULL;
}
WAVEFORMATEX wfe;