summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--configure.in15
-rw-r--r--plugins/ape/Makefile.am2
-rw-r--r--plugins/ape/ape.c3
4 files changed, 9 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index df1d9b58..ca124f87 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,6 @@ SUBDIRS = gme/Game_Music_Emu-0.5.2\
plugins/hotkeys\
plugins/lastfm\
plugins/demac\
- ${APE_DIR}\
${MPGMAD_DIR}\
${VORBIS_DIR}\
${FLAC_DIR}
diff --git a/configure.in b/configure.in
index 825ea3dc..3f03782b 100644
--- a/configure.in
+++ b/configure.in
@@ -30,13 +30,13 @@ PKG_CHECK_MODULES(LASTFM_DEPS, libcurl)
AX_EXT()
dnl ape plugin
-AC_CHECK_LIB([mac], [main], [HAVE_LIBMAC=1])
-if test ${HAVE_LIBMAC}; then
- APE_LIBS="-lmac"
- APE_DIR="plugins/ape"
- AC_SUBST(APE_LIBS)
- AC_SUBST(APE_DIR)
-fi
+dnl AC_CHECK_LIB([mac], [main], [HAVE_LIBMAC=1])
+dnl if test ${HAVE_LIBMAC}; then
+dnl APE_LIBS="-lmac"
+dnl APE_DIR="plugins/ape"
+dnl AC_SUBST(APE_LIBS)
+dnl AC_SUBST(APE_DIR)
+dnl fi
dnl mpgmad plugin
AC_CHECK_LIB([mad], [main], [HAVE_LIBMAD=1])
@@ -78,7 +78,6 @@ sid/sidplay-libs-2.1.0/Makefile
dumb/Makefile
plugins/hotkeys/Makefile
plugins/lastfm/Makefile
-plugins/ape/Makefile
plugins/demac/Makefile
plugins/mpgmad/Makefile
plugins/vorbis/Makefile
diff --git a/plugins/ape/Makefile.am b/plugins/ape/Makefile.am
index f36df197..d5678f4f 100644
--- a/plugins/ape/Makefile.am
+++ b/plugins/ape/Makefile.am
@@ -4,4 +4,4 @@ ape_la_SOURCES = ape.c apewrapper.cpp apewrapper.h
ape_la_LDFLAGS = -module
ape_la_LIBADD = $(LDADD) $(APE_LIBS)
-AM_CFLAGS = $(CFLAGS) -std=c99
+AM_CFLAGS = $(CFLAGS) -std=c99 -O0 -g
diff --git a/plugins/ape/ape.c b/plugins/ape/ape.c
index 4064666e..9443dfa2 100644
--- a/plugins/ape/ape.c
+++ b/plugins/ape/ape.c
@@ -90,7 +90,6 @@ ape_init (DB_playItem_t *it) {
neg = 1<<plugin.info.bps;
sign = (1<<31);
signshift = plugin.info.bps-1;
-
return 0;
}
@@ -178,13 +177,13 @@ ape_seek (float seconds) {
samplesdecoded = nblock;
ape_blocks_left = ape_total_blocks - nblock;
plugin.info.readpos = samplesdecoded / (float)plugin.info.samplerate - timestart;
+ return 0;
}
static DB_playItem_t *
ape_insert (DB_playItem_t *after, const char *fname) {
void *dec = ape_decompress_create (fname);
if (!dec) {
- ape_decompress_destroy (dec);
return NULL;
}
WAVEFORMATEX wfe;