summaryrefslogtreecommitdiff
path: root/plugins/shn
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-05-23 14:04:43 +0200
committerGravatar waker <wakeroid@gmail.com>2011-05-23 14:04:43 +0200
commit886dca87c46502de6dc7ca5a78acfb8e1b259890 (patch)
tree2ca74b4cc7ad17861c9f6e067df14a7301ed3581 /plugins/shn
parente500400f8a60c3d0656896fb035f3cc1cec5a1f7 (diff)
added ddb_ prefix to dumb, shn and ao plugins;
ao has been renamed to ddb_aopsf; tweaked sources and makefiles to simplify compiling out of tree
Diffstat (limited to 'plugins/shn')
-rw-r--r--plugins/shn/Makefile7
-rw-r--r--plugins/shn/shn.c4
-rw-r--r--plugins/shn/shn.h2
3 files changed, 7 insertions, 6 deletions
diff --git a/plugins/shn/Makefile b/plugins/shn/Makefile
index 7ce0e430..d76c8427 100644
--- a/plugins/shn/Makefile
+++ b/plugins/shn/Makefile
@@ -1,8 +1,9 @@
-OUT=shn.so
+OUT=ddb_shn.so
-CC=gcc
+CC?=gcc
-CFLAGS+=-Wall -fPIC -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I../..
+CFLAGS?=-I../..
+CFLAGS+=-Wall -fPIC -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I.
LDFLAGS+=-module -shared -lm
diff --git a/plugins/shn/shn.c b/plugins/shn/shn.c
index 881cf3b7..504f283c 100644
--- a/plugins/shn/shn.c
+++ b/plugins/shn/shn.c
@@ -23,7 +23,7 @@
#include <stdlib.h>
#include <math.h>
#include "shorten.h"
-#include "../../deadbeef.h"
+#include <deadbeef/deadbeef.h>
#include "bitshift.h"
//#define trace(...) { fprintf(stderr, __VA_ARGS__); }
@@ -1836,7 +1836,7 @@ static DB_decoder_t plugin = {
};
DB_plugin_t *
-shn_load (DB_functions_t *api) {
+ddb_shn_load (DB_functions_t *api) {
deadbeef = api;
return DB_PLUGIN (&plugin);
}
diff --git a/plugins/shn/shn.h b/plugins/shn/shn.h
index 518334bc..e7d3bba8 100644
--- a/plugins/shn/shn.h
+++ b/plugins/shn/shn.h
@@ -28,7 +28,7 @@
#include <stdio.h>
#include <unistd.h>
#include <sys/stat.h>
-#include "../../deadbeef.h"
+#include <deadbeef/deadbeef.h>
extern DB_functions_t *deadbeef;