summaryrefslogtreecommitdiff
path: root/plugins/shn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shn/Makefile')
-rw-r--r--plugins/shn/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/plugins/shn/Makefile b/plugins/shn/Makefile
index 7ce0e430..d76c8427 100644
--- a/plugins/shn/Makefile
+++ b/plugins/shn/Makefile
@@ -1,8 +1,9 @@
-OUT=shn.so
+OUT=ddb_shn.so
-CC=gcc
+CC?=gcc
-CFLAGS+=-Wall -fPIC -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I../..
+CFLAGS?=-I../..
+CFLAGS+=-Wall -fPIC -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I.
LDFLAGS+=-module -shared -lm