summaryrefslogtreecommitdiff
path: root/plugins/shn
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2010-12-04 16:01:21 +0100
committerGravatar waker <wakeroid@gmail.com>2010-12-04 16:01:21 +0100
commit5a4dcbeed4abc92ccd72bc38a4322f60f8208ee8 (patch)
treec117ffd25519f5a04eae3dbd3e7e5f36537a67b9 /plugins/shn
parentb9591350f82d2301517e9bc49872b26fc83c56fd (diff)
removed shn plugin from tarball
Diffstat (limited to 'plugins/shn')
-rw-r--r--plugins/shn/Makefile22
-rw-r--r--plugins/shn/Makefile.am10
2 files changed, 22 insertions, 10 deletions
diff --git a/plugins/shn/Makefile b/plugins/shn/Makefile
new file mode 100644
index 00000000..a87ac1ec
--- /dev/null
+++ b/plugins/shn/Makefile
@@ -0,0 +1,22 @@
+OUT=shn.so
+
+CC=gcc
+
+CFLAGS=-Wall -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I../..
+
+LDFLAGS=-module -shared -fPIC -lm
+
+SOURCES=array.c convert.c misc.c output.c seek.c shn.c shorten.c sulawalaw.c vario.c wave.c
+
+OBJECTS=$(SOURCES:.c=.o)
+
+all: $(SOURCES) $(OUT)
+
+$(OUT): $(OBJECTS)
+ $(CC) $(LDFLAGS) $(OBJECTS) -o $@
+
+.c.o:
+ $(CC) $(CFLAGS) $< -c -o $@
+
+clean:
+ rm $(OBJECTS) $(OUT)
diff --git a/plugins/shn/Makefile.am b/plugins/shn/Makefile.am
deleted file mode 100644
index 335dacff..00000000
--- a/plugins/shn/Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
-if HAVE_SHN
-shndir = $(libdir)/$(PACKAGE)
-pkglib_LTLIBRARIES = shn.la
-shn_la_SOURCES = array.c convert.c misc.c output.c seek.c shn.c shn.h shorten.c shorten.h sulawalaw.c vario.c wave.c bitshift.h
-
-shn_la_LDFLAGS = -module
-
-shn_la_LIBADD = $(LDADD) -lm
-AM_CFLAGS = $(CFLAGS) -std=c99
-endif