summaryrefslogtreecommitdiff
path: root/plugins/shn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shn/Makefile')
-rw-r--r--plugins/shn/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/plugins/shn/Makefile b/plugins/shn/Makefile
new file mode 100644
index 00000000..a87ac1ec
--- /dev/null
+++ b/plugins/shn/Makefile
@@ -0,0 +1,22 @@
+OUT=shn.so
+
+CC=gcc
+
+CFLAGS=-Wall -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I../..
+
+LDFLAGS=-module -shared -fPIC -lm
+
+SOURCES=array.c convert.c misc.c output.c seek.c shn.c shorten.c sulawalaw.c vario.c wave.c
+
+OBJECTS=$(SOURCES:.c=.o)
+
+all: $(SOURCES) $(OUT)
+
+$(OUT): $(OBJECTS)
+ $(CC) $(LDFLAGS) $(OBJECTS) -o $@
+
+.c.o:
+ $(CC) $(CFLAGS) $< -c -o $@
+
+clean:
+ rm $(OBJECTS) $(OUT)