summaryrefslogtreecommitdiff
path: root/plugins/mono2stereo
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-10-23 18:32:00 +0200
committerGravatar waker <wakeroid@gmail.com>2011-10-23 18:32:00 +0200
commit0a0f6f591163203c8156d5079061ab2010acbdd3 (patch)
tree67170afeadd67f91a8cbbc1d7b03181d79ba5a41 /plugins/mono2stereo
parente456e4f6294d829633982105888f77bda1cb1e48 (diff)
few compile fixes; added mono2stereo into tarball
Diffstat (limited to 'plugins/mono2stereo')
-rw-r--r--plugins/mono2stereo/Makefile23
-rw-r--r--plugins/mono2stereo/Makefile.am8
-rw-r--r--plugins/mono2stereo/mono2stereo.c2
3 files changed, 9 insertions, 24 deletions
diff --git a/plugins/mono2stereo/Makefile b/plugins/mono2stereo/Makefile
deleted file mode 100644
index 0dceaa3a..00000000
--- a/plugins/mono2stereo/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-CC?=gcc
-
-CFLAGS+=-Wall -fPIC -D_GNU_SOURCE -std=c99
-
-LDFLAGS+=-module -shared -lm
-
-SOURCES=mono2stereo.c
-
-OBJECTS=$(SOURCES:.c=.o)
-
-OUT?=ddb_mono2stereo.so
-
-all: $(SOURCES) $(OUT)
-
-$(OUT): $(OBJECTS)
- $(CC) $(LDFLAGS) $(OBJECTS) -o $@
-
-.c.o:
- $(CC) $(CFLAGS) $< -c -o $@
-
-clean:
- rm $(OBJECTS) $(OUT)
-
diff --git a/plugins/mono2stereo/Makefile.am b/plugins/mono2stereo/Makefile.am
new file mode 100644
index 00000000..ccbbf846
--- /dev/null
+++ b/plugins/mono2stereo/Makefile.am
@@ -0,0 +1,8 @@
+if HAVE_MONO2STEREO
+pkglib_LTLIBRARIES = ddb_mono2stereo.la
+ddb_mono2stereo_la_SOURCES = mono2stereo.c
+ddb_mono2stereo_la_LDFLAGS = -module
+
+ddb_mono2stereo_la_LIBADD = $(LDADD)
+AM_CFLAGS = $(CFLAGS) -std=c99
+endif
diff --git a/plugins/mono2stereo/mono2stereo.c b/plugins/mono2stereo/mono2stereo.c
index 23d0b0d5..66168bed 100644
--- a/plugins/mono2stereo/mono2stereo.c
+++ b/plugins/mono2stereo/mono2stereo.c
@@ -19,7 +19,7 @@
#include <stdlib.h>
#include <string.h>
#include <assert.h>
-#include <deadbeef/deadbeef.h>
+#include "../../deadbeef.h"
enum {
M2S_PARAM_LEFTMIX,