summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Ian Nartowicz <iann@crunchbang>2014-06-10 00:01:48 +0100
committerGravatar Ian Nartowicz <iann@crunchbang>2014-06-10 00:01:48 +0100
commitd76eec34fc9a2544bc768028719119690739b60b (patch)
treefe9368a90bba45150e76adb2c72496f36707ca66 /configure.ac
parent275a317a897bff132da44105d9dd6b12811f98d0 (diff)
Possible conditional compilation flag for liboggedit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76338d66..57d87e90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -384,6 +384,7 @@ AS_IF([test "${enable_staticlink}" != "no"], [
])
])
+AC_CHECK_LIB([ogg], [ogg_stream_flush_fill], [HAVE_OGG_STREAM_FLUSH_FILL=yes])
dnl flac plugin
AS_IF([test "${enable_flac}" != "no"], [
@@ -752,6 +753,10 @@ PLUGINS_DIRS="plugins/liboggedit plugins/libmp4ff plugins/libparser plugins/last
AM_CONDITIONAL(APE_USE_YASM, test "x$APE_USE_YASM" = "xyes")
AM_CONDITIONAL(HAVE_VORBIS, test "x$HAVE_VORBISPLUGIN" = "xyes")
AM_CONDITIONAL(HAVE_OGG, test "x$HAVE_OGG" = "xyes")
+<<<<<<< HEAD
+=======
+AM_CONDITIONAL(HAVE_OGG_STREAM_FLUSH_FILL, test "x$HAVE_OGG_STREAM_FLUSH_FILL" = "xyes")
+>>>>>>> Possible conditional compilation for padding
AM_CONDITIONAL(HAVE_FLAC, test "x$HAVE_FLACPLUGIN" = "xyes")
AM_CONDITIONAL(HAVE_WAVPACK, test "x$HAVE_WAVPACKPLUGIN" = "xyes")
AM_CONDITIONAL(HAVE_SNDFILE, test "x$HAVE_SNDFILEPLUGIN" = "xyes")