summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Lithopsian <deadbeef@nartowicz.co.uk>2014-06-09 22:11:51 +0100
committerGravatar Lithopsian <deadbeef@nartowicz.co.uk>2014-06-09 22:11:51 +0100
commit275a317a897bff132da44105d9dd6b12811f98d0 (patch)
tree048b02ff66d7535a4461aba57c0ef60989617cf5 /configure.ac
parent1cd417fc09faec13357268141767b24b8033eea7 (diff)
parentbce5dcb98fffae72a960ea5b85cc27a5af0ff01e (diff)
Merge pull request #1 from Alexey-Yakovenko/master
Sync with head changes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2e388de4..76338d66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,7 +353,7 @@ dnl vorbis plugin
AS_IF([test "${enable_vorbis}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_VORBISPLUGIN=yes
- VORBIS_LIBS="../../$LIB/lib/libogg.a ../../$LIB/lib/libvorbis.a ../../$LIB/lib/libvorbisenc.a ../../$LIB/lib/libvorbisfile.a"
+ VORBIS_LIBS="-lvorbisfile -lvorbis -lm -logg"
VORBIS_CFLAGS="-I../../$LIB/include"
AC_SUBST(VORBIS_LIBS)
AC_SUBST(VORBIS_CFLAGS)
@@ -368,12 +368,29 @@ AS_IF([test "${enable_vorbis}" != "no"], [
])
])
+dnl libogg for oggedit
+AS_IF([test "${enable_staticlink}" != "no"], [
+ HAVE_OGG=yes
+ OGG_LIBS="-logg"
+ OGG_CFLAGS="-I../../$LIB/include"
+ AC_SUBST(OGG_LIBS)
+ AC_SUBST(OGG_CFLAGS)
+], [
+ AC_CHECK_LIB([ogg], [main], [HAVE_OGG=yes])
+ AS_IF([test "$HAVE_OGG" = "yes"], [
+ HAVE_VORBISPLUGIN=yes
+ OGG_LIBS="-logg"
+ AC_SUBST(OGG_LIBS)
+ ])
+])
+
+
dnl flac plugin
AS_IF([test "${enable_flac}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_FLACPLUGIN=yes
FLAC_CFLAGS="-I../../$LIB/include"
- FLAC_LIBS="../../$LIB/lib/libFLAC.a ../../$LIB/lib/libogg.a"
+ FLAC_LIBS="-lFLAC"
AC_SUBST(FLAC_CFLAGS)
AC_SUBST(FLAC_LIBS)
], [
@@ -734,6 +751,7 @@ PLUGINS_DIRS="plugins/liboggedit plugins/libmp4ff plugins/libparser plugins/last
AM_CONDITIONAL(APE_USE_YASM, test "x$APE_USE_YASM" = "xyes")
AM_CONDITIONAL(HAVE_VORBIS, test "x$HAVE_VORBISPLUGIN" = "xyes")
+AM_CONDITIONAL(HAVE_OGG, test "x$HAVE_OGG" = "xyes")
AM_CONDITIONAL(HAVE_FLAC, test "x$HAVE_FLACPLUGIN" = "xyes")
AM_CONDITIONAL(HAVE_WAVPACK, test "x$HAVE_WAVPACKPLUGIN" = "xyes")
AM_CONDITIONAL(HAVE_SNDFILE, test "x$HAVE_SNDFILEPLUGIN" = "xyes")