summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-13 10:13:43 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-13 10:13:43 +0200
commit9af0aa32c1e32e7ac841c624e0c4f383430e2efd (patch)
treea281840577f9732c843bb63e844cf3cda5e46580
parentea5dabc28a719e57b59ea0852f89cb0002caa43b (diff)
desktop icons, launcher update, minor libsidplay2 patches
-rw-r--r--Makefile.am1
-rw-r--r--acinclude.m494
-rw-r--r--configure.in12
-rw-r--r--deadbeef.desktop.in7
-rw-r--r--icons/16x16/deadbeef.pngbin0 -> 673 bytes
-rw-r--r--icons/32x32/deadbeef.pngbin0 -> 1737 bytes
-rw-r--r--icons/48x48/deadbeef.pngbin0 -> 3261 bytes
-rw-r--r--icons/Makefile.am11
-rw-r--r--sid/sidplay-libs-2.1.0/Makefile.am2
-rw-r--r--sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidconfig.h8
-rw-r--r--sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidint.h8
11 files changed, 110 insertions, 33 deletions
diff --git a/Makefile.am b/Makefile.am
index 6491f52e..4b29261a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@ SUBDIRS = gme/Game_Music_Emu-0.5.2\
sid/sidplay-libs-2.1.0\
dumb\
pixmaps\
+ icons\
plugins/hotkeys\
plugins/ffap\
${LFM_DIR}\
diff --git a/acinclude.m4 b/acinclude.m4
index 2fc21e91..81aeedfb 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -108,13 +108,30 @@ AC_LANG_POP([C])
])
-
# ===========================================================================
-# http://autoconf-archive.cryp.to/ax_ext.html
+# http://www.nongnu.org/autoconf-archive/ax_ext.html
# ===========================================================================
#
+# SYNOPSIS
#
-# COPYLEFT
+# AX_EXT
+#
+# DESCRIPTION
+#
+# Find supported SIMD extensions by requesting cpuid. When an SIMD
+# extension is found, the -m"simdextensionname" is added to SIMD_FLAGS
+# (only if compilator support it) (ie : if "sse2" is available "-msse2" is
+# added to SIMD_FLAGS)
+#
+# This macro calls:
+#
+# AC_SUBST(SIMD_FLAGS)
+#
+# And defines:
+#
+# HAVE_MMX / HAVE_SSE / HAVE_SSE2 / HAVE_SSE3 / HAVE_SSSE3
+#
+# LICENSE
#
# Copyright (c) 2008 Christophe Tournayre <turn3r@users.sourceforge.net>
#
@@ -124,28 +141,83 @@ AC_LANG_POP([C])
AC_DEFUN([AX_EXT],
[
- #AC_REQUIRE([AX_GCC_X86_CPUID])
+ AC_REQUIRE([AX_GCC_X86_CPUID])
AX_GCC_X86_CPUID(0x00000001)
ecx=`echo $ax_cv_gcc_x86_cpuid_0x00000001 | cut -d ":" -f 3`
edx=`echo $ax_cv_gcc_x86_cpuid_0x00000001 | cut -d ":" -f 4`
-
if test "x$edx" = "xunknown"; then
+ ax_have_mmx_ext=no
+ ax_have_sse_ext=no
+ ax_have_sse_ext=no
ax_have_sse2_ext=no
-
+ ax_have_sse3_ext=no
+ ax_have_ssse3_ext=no
else
- AC_CACHE_CHECK([whether sse2 is supported], [ax_have_sse2_ext],
+
+ AC_CACHE_CHECK([whether mmx is supported], [ax_have_mmx_ext],
+ [
+ ax_have_mmx_ext=no
+ if test "$((0x$edx>>23&0x01))" = 1; then
+ ax_have_mmx_ext=yes
+ fi
+ ])
+
+ AC_CACHE_CHECK([whether sse is supported], [ax_have_sse_ext],
+ [
+ ax_have_sse_ext=no
+ if test "$((0x$edx>>25&0x01))" = 1; then
+ ax_have_sse_ext=yes
+ fi
+ ])
+
+ AC_CACHE_CHECK([whether sse2 is supported], [ax_have_sse2_ext],
[
ax_have_sse2_ext=no
if test "$((0x$edx>>26&0x01))" = 1; then
ax_have_sse2_ext=yes
fi
])
- fi
- if test "$ax_have_sse2_ext" = yes; then
- AC_DEFINE(HAVE_SSE2, , [Support SSE2 (Streaming SIMD Extensions 2) instructions])
- AX_CHECK_COMPILER_FLAGS(-msse2, SIMD_FLAGS="$SIMD_FLAGS -msse2", [])
+ AC_CACHE_CHECK([whether sse3 is supported], [ax_have_sse3_ext],
+ [
+ ax_have_sse3_ext=no
+ if test "$((0x$ecx&0x01))" = 1; then
+ ax_have_sse3_ext=yes
+ fi
+ ])
+
+ AC_CACHE_CHECK([whether ssse3 is supported], [ax_have_ssse3_ext],
+ [
+ ax_have_ssse3_ext=no
+ if test "$((0x$ecx>>9&0x01))" = 1; then
+ ax_have_ssse3_ext=yes
+ fi
+ ])
+
+ if test "$ax_have_mmx_ext" = yes; then
+ AC_DEFINE(HAVE_MMX,,[Support mmx instructions])
+ AX_CHECK_COMPILER_FLAGS(-mmmx, SIMD_FLAGS="$SIMD_FLAGS -mmmx", [])
+ fi
+
+ if test "$ax_have_sse_ext" = yes; then
+ AC_DEFINE(HAVE_SSE,,[Support SSE (Streaming SIMD Extensions) instructions])
+ AX_CHECK_COMPILER_FLAGS(-msse, SIMD_FLAGS="$SIMD_FLAGS -msse", [])
+ fi
+
+ if test "$ax_have_sse2_ext" = yes; then
+ AC_DEFINE(HAVE_SSE2,,[Support SSE2 (Streaming SIMD Extensions 2) instructions])
+ AX_CHECK_COMPILER_FLAGS(-msse2, SIMD_FLAGS="$SIMD_FLAGS -msse2", [])
+ fi
+
+ if test "$ax_have_sse3_ext" = yes; then
+ AC_DEFINE(HAVE_SSE3,,[Support SSE3 (Streaming SIMD Extensions 3) instructions])
+ AX_CHECK_COMPILER_FLAGS(-msse3, SIMD_FLAGS="$SIMD_FLAGS -msse3", [])
+ fi
+
+ if test "$ax_have_ssse3_ext" = yes; then
+ AC_DEFINE(HAVE_SSSE3,,[Support SSSE3 (Supplemental Streaming SIMD Extensions 3) instructions])
+ fi
fi
AC_SUBST(SIMD_FLAGS)
diff --git a/configure.in b/configure.in
index 6f131da3..fa5fb6c0 100644
--- a/configure.in
+++ b/configure.in
@@ -16,12 +16,17 @@ AC_PROG_LIBTOOL
LT_INIT
AC_CONFIG_MACRO_DIR([m4])
AC_C_BIGENDIAN
-AC_DEFINE([PREFIX], [], [Installation prefix])
test "x$prefix" = xNONE && prefix=$ac_default_prefix
-AC_DEFINE_UNQUOTED(PREFIX, "${prefix}")
-CFLAGS="$CFLAGS -D_GNU_SOURCE -O2 -DHAVE_UNIX"
+dnl AC_DEFINE([PREFIX], [], [Installation prefix])
+dnl AC_DEFINE_UNQUOTED(PREFIX, "${prefix}")
+dnl
+dnl AC_DEFINE([LIBDIR], [], [Library path])
+dnl LIBDIR="${libdir}"
+dnl AC_DEFINE_UNQUOTED(LIBDIR, "$LIBDIR")
+
+CFLAGS="$CFLAGS -D_GNU_SOURCE -DLIBDIR=\\\"$libdir\\\" -DPREFIX=\\\"$prefix\\\""
CPPFLAGS="$CFLAGS"
PKG_CHECK_MODULES(DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0 samplerate alsa)
@@ -71,6 +76,7 @@ fi
AC_OUTPUT([
Makefile
pixmaps/Makefile
+icons/Makefile
gme/Game_Music_Emu-0.5.2/Makefile
gme/Game_Music_Emu-0.5.2/gme/Makefile
sid/sidplay-libs-2.1.0/Makefile
diff --git a/deadbeef.desktop.in b/deadbeef.desktop.in
index 43d8e644..bc729a64 100644
--- a/deadbeef.desktop.in
+++ b/deadbeef.desktop.in
@@ -3,9 +3,8 @@ Name=Deadbeef
GenericName=Audio Player
Comment=Play music
Exec=deadbeef %U
-MimeType=application/ogg;audio/x-vorbis+ogg;application/x-ogg;audio/mp3;audio/prs.sid;audio/x-flac;audio/mpeg;audio/x-mpeg;audio/x-mod;audio/x-it;audio/x-s3m;audio/x-xm
-Categories=Application;AudioVideo;Player
+MimeType=application/ogg;audio/x-vorbis+ogg;application/x-ogg;audio/mp3;audio/prs.sid;audio/x-flac;audio/mpeg;audio/x-mpeg;audio/x-mod;audio/x-it;audio/x-s3m;audio/x-xm;
+Categories=AudioVideo;Player;
Terminal=false
Type=Application
-Encoding=UTF-8
-#Icon=
+Icon=deadbeef
diff --git a/icons/16x16/deadbeef.png b/icons/16x16/deadbeef.png
new file mode 100644
index 00000000..829b238c
--- /dev/null
+++ b/icons/16x16/deadbeef.png
Binary files differ
diff --git a/icons/32x32/deadbeef.png b/icons/32x32/deadbeef.png
new file mode 100644
index 00000000..1abdb062
--- /dev/null
+++ b/icons/32x32/deadbeef.png
Binary files differ
diff --git a/icons/48x48/deadbeef.png b/icons/48x48/deadbeef.png
new file mode 100644
index 00000000..64ddae2c
--- /dev/null
+++ b/icons/48x48/deadbeef.png
Binary files differ
diff --git a/icons/Makefile.am b/icons/Makefile.am
new file mode 100644
index 00000000..835070e6
--- /dev/null
+++ b/icons/Makefile.am
@@ -0,0 +1,11 @@
+icon16dir=$(prefix)/share/icons/hicolor/16x16/apps
+icon16_DATA=16x16/deadbeef.png
+EXTRADIST = $(icon16_DATA)
+
+icon32dir=$(prefix)/share/icons/hicolor/32x32/apps
+icon32_DATA=32x32/deadbeef.png
+EXTRADIST = $(icon32_DATA)
+
+icon48dir=$(prefix)/share/icons/hicolor/48x48/apps
+icon48_DATA=48x48/deadbeef.png
+EXTRADIST = $(icon48_DATA)
diff --git a/sid/sidplay-libs-2.1.0/Makefile.am b/sid/sidplay-libs-2.1.0/Makefile.am
index 9e52270e..8466cefb 100644
--- a/sid/sidplay-libs-2.1.0/Makefile.am
+++ b/sid/sidplay-libs-2.1.0/Makefile.am
@@ -7,7 +7,7 @@ EXTRA_DIST = \
$(sidpath)/libsidutils/COPYING $(sidpath)/libsidplay/COPYING $(sidpath)/resid/COPYING\
$(sidpath)/libsidutils/AUTHORS $(sidpath)/libsidplay/AUTHORS $(sidpath)/resid/AUTHORS
-AM_CPPFLAGS = $(CPPFLAGS) -DVERSION=\"2.1.0\" -DHAVE_STRNCASECMP -DHAVE_STRCASECMP -I$(sidpath)/libsidplay -I$(sidpath)/libsidplay/include -I$(sidpath)/libsidplay/include/sidplay -I$(sidpath)/libsidutils/include/sidplay/utils -I$(sidpath)/builders/resid-builder/include/sidplay/builders -I$(sidpath)/builders/resid-builder/include
+AM_CPPFLAGS = $(CPPFLAGS) -DHAVEUNIX -DVERSION=\"2.1.0\" -DHAVE_STRNCASECMP -DHAVE_STRCASECMP -I$(sidpath)/libsidplay -I$(sidpath)/libsidplay/include -I$(sidpath)/libsidplay/include/sidplay -I$(sidpath)/libsidutils/include/sidplay/utils -I$(sidpath)/builders/resid-builder/include/sidplay/builders -I$(sidpath)/builders/resid-builder/include
libsidplay2_a_SOURCES = \
libsidplay/src/mixer.cpp\
diff --git a/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidconfig.h b/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidconfig.h
index fa8af23e..f158dc9a 100644
--- a/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidconfig.h
+++ b/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidconfig.h
@@ -24,10 +24,4 @@
*
***************************************************************************/
-#if defined(HAVE_UNIX)
-# include "../../unix/sidconfig.h"
-#elif defined(HAVE_MSWINDOWS)
-# include "../../win/VC/sidconfig.h"
-#else
-# error Platform not supported!
-#endif
+#include "../../unix/sidconfig.h"
diff --git a/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidint.h b/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidint.h
index c2387d78..7f26ccea 100644
--- a/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidint.h
+++ b/sid/sidplay-libs-2.1.0/libsidplay/include/sidplay/sidint.h
@@ -15,10 +15,4 @@
* *
***************************************************************************/
-#if defined(HAVE_UNIX)
-# include "../../unix/sidint.h"
-#elif defined(HAVE_MSWINDOWS)
-# include "../../win/VC/sidint.h"
-#else
-# error Platform not supported!
-#endif
+#include "../../unix/sidint.h"