summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-12 23:06:21 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-12 23:06:21 +0200
commitea5dabc28a719e57b59ea0852f89cb0002caa43b (patch)
treeeed566b02df2e5b2a0ba67f3fead6a8744ed4e57
parentf862e75a461d021833d4409fef154739812408d8 (diff)
minor updates following 0.2.1
-rw-r--r--ChangeLog2
-rw-r--r--PKGBUILD6
-rw-r--r--web/index.html32
3 files changed, 29 insertions, 11 deletions
diff --git a/ChangeLog b/ChangeLog
index 71bc5fe7..9a409b14 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -3,7 +3,7 @@ version 0.2.1
fixed APEv2 tag reader
fixed id3 tag reader on big-endian systems
player now builds without errors on big-endian systems
- memory for HSVC song length database is now allocated on demand
+ memory for HVSC song length database is now allocated on demand
fixed icons in system tray menu
fixed color detection for column header text
improved cuesheet reader (pregap support and better bounds checking)
diff --git a/PKGBUILD b/PKGBUILD
index db735e70..5f71307b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alexey Yakovenko <waker@users.sourceforge.net>
pkgname=deadbeef
-pkgver=0.2.0
+pkgver=0.2.1
pkgrel=1
-pkgdesc="mp3/ogg/flac/sid/mod/nsf music player based on GTK2"
+pkgdesc="mp3/ogg/flac/ape/sid/mod/nsf music player based on GTK2"
arch=(i686 x86_64)
url="http://deadbeef.sourceforge.net"
license=('GPL2')
@@ -12,7 +12,7 @@ depends=('gtk2' 'libsamplerate' 'alsa-lib')
optdepends=('libvorbis: ogg vorbis playback', 'libmad: mp1/2/3 playback', 'flac: flac playback', 'curl: lastfm scrobbler')
makedepends=('pkgconfig')
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('62bb5c8cc29db463811aea39b47bd780')
+md5sums=('5b9de8962d77eea2748208d9ed563952')
build() {
cd $srcdir/$pkgname-$pkgver
diff --git a/web/index.html b/web/index.html
index b442ce2a..1550372c 100644
--- a/web/index.html
+++ b/web/index.html
@@ -49,6 +49,23 @@
<h1 id="news">News</h1>
+<h2>release 0.2.1 is out</h2>
+<div class="post">
+ <p class="date">2009/09/12</p>
+ <p><a href="#download">get it!</a></p>
+ <p>Changelog since 0.2.0</p>
+ <ul>
+ <li>new ape decoder - faster, doesn't crash</li>
+ <li>fixed APEv2 tag reader</li>
+ <li>fixed id3 tag reader on big-endian systems</li>
+ <li>player now builds without errors on big-endian systems</li>
+ <li>memory for HVSC song length database is now allocated on demand</li>
+ <li>fixed icons in system tray menu</li>
+ <li>fixed color detection for column header text</li>
+ <li>improved cuesheet reader (pregap support and better bounds checking)</li>
+ </ul>
+</div>
+
<h2>updated debian packages</h2>
<div class="post">
<p class="date">2009/09/12</p>
@@ -182,7 +199,7 @@ implemented basic session management, window size/position, volume, playmode are
<h2>Alpha released</h2>
<div class='post'>
-<p>first alpha release 0.1.0 just appened on Wed Aug 19 21:59:27 CEST 2009!</p>
+<p>first alpha release 0.1.0 just happened on Wed Aug 19 21:59:27 CEST 2009!</p>
<p>there was a report from a happy user that deadbeef won't compile with gtk&lt;=2.16.</p>
<p>fix is very easy, and will be available in next release, and in git head when i have time to prepare and push it</p>
<p>thanks for understanding and happy hacking!</p>
@@ -209,7 +226,7 @@ implemented basic session management, window size/position, volume, playmode are
<li>seeking works in all supported formats</li>
<li>plugin support; ships with several standard plugins, such as global hotkeys and last.fm scrobbler; sdk is included</li>
<li>duration calculation is as precise as possible for vbr mp3 files (with and without xing/info tags)</li>
- <li>fully functional on x86 and x86_64 architectures. (was also tested on ppc64 - works, but has some problems)</li>
+ <li>was tested and works on x86, x86_64 and ppc64 architectures. should work on most modern platforms</li>
</ul>
<h1 id="license">Copying</h1>
<pre>
@@ -232,16 +249,18 @@ implemented basic session management, window size/position, volume, playmode are
<h1 id="download">Download</h1>
<h2>Latest version:</h2>
-<p>source code for version 0.2.0 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.0.tar.gz/download">deadbeef-0.2.0.tar.gz</a></p>
<p>official Arch Linux PKGBUILD: <a href="http://aur.archlinux.org/packages.php?ID=29497">here</a></p>
<p>if you have yaourt, you can simply do yaourt -S deadbeef</p>
+<p>source code for version 0.2.1 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.1.tar.gz/download">deadbeef-0.2.1.tar.gz</a></p>
<p>or <a href="http://sourceforge.net/projects/deadbeef/files/">browse all files</a></p>
+<h2>version 0.2.0:</h2>
+<p>source code for version 0.2.0 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.0.tar.gz/download">deadbeef-0.2.0.tar.gz</a></p>
<p><b>unsupported</b> slackware package for version 0.2.0 from <a href="mailto:sftp.mtuci@gmail.com">sftp.mtuci@gmail.com</a>:</p>
<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.0-i686-slack12.2_1.tgz/download">i686 slackware 12.2</a></p>
<p><b>unsupported</b> debian packages for version 0.2.0 from <a href="mailto:alexey.smirnov@gmx.com">Alexey Smirnov</a>:</p>
<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.2-1_i386.deb/download">i386</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.2-1_amd64.deb/download">x86_64</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-plugins-dev_0.2-1_all.deb/download">plugin sdk</a></p>
<p>note: i have nothing to do with these packages, nor can i test them. use at your own risk</p>
-<h2>Old stuff</h2>
+<h2>version 0.1.1</h2>
<p>source code for version 0.1.1 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.1.1.tar.gz/download">deadbeef-0.1.1.tar.gz</a></p>
<p><b>unsupported</b> debian packages for version 0.1.1 from <a href="mailto:alexey.smirnov@gmx.com">Alexey Smirnov</a>:</p>
<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.1.1-1_i386.deb/download">i386</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.1.1-1_amd64.deb/download">x86_64</a></p>
@@ -257,13 +276,12 @@ implemented basic session management, window size/position, volume, playmode are
<h1 id='bugs'>Reporting Bugs And Requesting Features</h1>
<p>i don't want to receive bug reports or feature requests yet. but if you really feel like it - send me an <a href="mailto:waker@users.sourceforge.net">email</a>, or come to one of our irc/jabber chats.</p>
<h1 id="developers">Developer Information</h1>
-<p>if you want to contribute a patch, simply clone git repository, make new feature or fix a bug, and send me a link so that i can merge it.</p>
+<p>if you want to contribute a patch, simply clone git repository, make new feature or fix a bug, and use "git format-patch" to create patch. then you can send it to me over email.</p>
<p>see <a href="http://sourceforge.net/projects/deadbeef">project site</a> for details.</p>
<h1 id='contacts'>Contacts</h1>
-<p>official IRC channel is: #deadbeefplayer @ freenode</p>
+<p>official IRC channel (for english speaking people) is: #deadbeefplayer @ freenode</p>
<p>official jabber conference for russian speaking users is here: deadbeef-ru@conference.jabber.ru</p>
<p>email: <a href="mailto:waker@users.sourceforge.net">Alexey Yakovenko</a></p>
-<p>keep in mind there's no stable release yet.</p>
<h1 id='screenshots'>Screenshots</h1>
<img src="https://sourceforge.net/dbimage.php?id=228167" alt="main window, version 0.1.0"/>