summaryrefslogtreecommitdiff
path: root/Source/Dafny/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Source/Dafny/Makefile')
-rw-r--r--Source/Dafny/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Source/Dafny/Makefile b/Source/Dafny/Makefile
index 2013b4f9..4c01c780 100644
--- a/Source/Dafny/Makefile
+++ b/Source/Dafny/Makefile
@@ -1,18 +1,19 @@
-COCO = Coco.exe
# ###############################################################################
# The frame files are no longer in this directory. They must be downloaded
# from http://boogiepartners.codeplex.com/. Update the FRAME_DIR variable to
# point to whatever directory you install that into.
# ###############################################################################
+COCO_EXE_DIR = ..\..\..\boogiepartners\CocoRdownload
FRAME_DIR = ..\..\..\boogiepartners\CocoR\Modified
+COCO = $(COCO_EXE_DIR)\Coco.exe
# "all" depends on 2 files, really (Parser.cs and Scanner.cs), but they
# are both generated in one go and I don't know a better way to tell
# nmake that. --KRML
all: Parser.cs
-Parser.cs: $(FRAME_DIR)\Scanner.frame $(FRAME_DIR)\Parser.frame Dafny.atg
+Parser.cs: $(FRAME_DIR)\scanner.frame $(FRAME_DIR)\parser.frame Dafny.atg
$(COCO) Dafny.atg -namespace Microsoft.Dafny -frames $(FRAME_DIR)
clean: