summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Rustan Leino <leino@microsoft.com>2012-10-04 19:26:54 -0700
committerGravatar Rustan Leino <leino@microsoft.com>2012-10-04 19:26:54 -0700
commit5558ba719abd8c9f6184e9d1b70afccfec649a6d (patch)
tree5c0538b126f5980a542eba3b99f9ef59b02a379b
parenta4af24114ae44ee34246fdc8bd16ce05d5518c20 (diff)
Fixed some goof-ups in the test script edits
Changed the test output to make it easier to spot (in the console output) that everything passed with success or if there were any failures
-rw-r--r--Test/Makefile8
-rw-r--r--Test/VSComp2010/runtest.bat2
-rw-r--r--Test/VSI-Benchmarks/runtest.bat2
-rw-r--r--Test/dafny0/runtest.bat2
-rw-r--r--Test/dafny1/runtest.bat2
-rw-r--r--Test/dafny2/runtest.bat2
-rw-r--r--Test/dafny3/runtest.bat2
-rw-r--r--Test/runtest.bat4
-rw-r--r--Test/vacid0/runtest.bat2
-rw-r--r--Test/vstte2012/runtest.bat2
10 files changed, 14 insertions, 14 deletions
diff --git a/Test/Makefile b/Test/Makefile
index 92c67ae4..6e02aed0 100644
--- a/Test/Makefile
+++ b/Test/Makefile
@@ -7,11 +7,11 @@ all: dafny
dafny: $(addprefix rundfy-, $(TESTS))
-show:
- @echo $(TESTS)
+rundfy-%:
+ @cmd /c "runtest.bat $* $(FLAGS)" || :
long:
$(MAKE) TESTS="$(NORMAL) $(LONG)" all
-rundfy-%:
- @if ls -f $*/*.dfy >/dev/null 2>&1 ; then cmd /c "runtest.bat $* $(FLAGS)" ; fi || :
+show:
+ @echo $(TESTS)
diff --git a/Test/VSComp2010/runtest.bat b/Test/VSComp2010/runtest.bat
index 9206f51e..4e6d170b 100644
--- a/Test/VSComp2010/runtest.bat
+++ b/Test/VSComp2010/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (Problem1-SumMax.dfy Problem2-Invert.dfy
Problem3-FindZero.dfy Problem4-Queens.dfy
diff --git a/Test/VSI-Benchmarks/runtest.bat b/Test/VSI-Benchmarks/runtest.bat
index 8f6dfc40..bbb9e3d7 100644
--- a/Test/VSI-Benchmarks/runtest.bat
+++ b/Test/VSI-Benchmarks/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (b1.dfy b2.dfy b3.dfy b4.dfy b5.dfy b6.dfy b7.dfy b8.dfy) do (
echo.
diff --git a/Test/dafny0/runtest.bat b/Test/dafny0/runtest.bat
index 9ebf88ae..4613b085 100644
--- a/Test/dafny0/runtest.bat
+++ b/Test/dafny0/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (Simple.dfy) do (
echo.
diff --git a/Test/dafny1/runtest.bat b/Test/dafny1/runtest.bat
index 60b562d0..467bedca 100644
--- a/Test/dafny1/runtest.bat
+++ b/Test/dafny1/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (Queue.dfy PriorityQueue.dfy
ExtensibleArray.dfy ExtensibleArrayAuto.dfy
diff --git a/Test/dafny2/runtest.bat b/Test/dafny2/runtest.bat
index 126b6001..72706d8f 100644
--- a/Test/dafny2/runtest.bat
+++ b/Test/dafny2/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
REM soon again: SnapshotableTrees.dfy
for %%f in (
diff --git a/Test/dafny3/runtest.bat b/Test/dafny3/runtest.bat
index a7b201e1..35d8cc60 100644
--- a/Test/dafny3/runtest.bat
+++ b/Test/dafny3/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (Iter.dfy) do (
echo.
diff --git a/Test/runtest.bat b/Test/runtest.bat
index 5b3d45ae..667ca579 100644
--- a/Test/runtest.bat
+++ b/Test/runtest.bat
@@ -11,11 +11,11 @@ rem Calling fc twice seems to fix (or at least alleviate) the problem.
fc /W Answer Output > nul
fc /W Answer Output > nul
if not errorlevel 1 goto passTest
-echo %1 FAILED
+echo ============ %1 FAILED ============
goto errorEnd
:passTest
-echo %1 Succeeded
+echo Success: %1
goto end
:noDirSpecified
diff --git a/Test/vacid0/runtest.bat b/Test/vacid0/runtest.bat
index b7d5f4d8..63fd2001 100644
--- a/Test/vacid0/runtest.bat
+++ b/Test/vacid0/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (LazyInitArray.dfy SparseArray.dfy Composite.dfy) do (
echo.
diff --git a/Test/vstte2012/runtest.bat b/Test/vstte2012/runtest.bat
index c2236cf7..ecccd929 100644
--- a/Test/vstte2012/runtest.bat
+++ b/Test/vstte2012/runtest.bat
@@ -2,7 +2,7 @@
setlocal
set BINARIES=..\..\Binaries
-set DAFNY_EXE=%BINARIES\Dafny.exe
+set DAFNY_EXE=%BINARIES%\Dafny.exe
for %%f in (
Two-Way-Sort.dfy