summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-06-16 14:41:51 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-06-16 14:41:51 +0000
commite978da8c41d8a3c19a29036d9c569fbe2a4616b0 (patch)
tree0de2a907ee93c795978f3c843155bee91c11ed60 /config
parent3ef7797ef6fc605dfafb32523261fe1b023aeecb (diff)
Imported Upstream version 8.0pl3+8.1betaupstream/8.0pl3+8.1beta
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template6
-rw-r--r--config/coq_config.mli3
2 files changed, 8 insertions, 1 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index 9432a884..aa7f2d62 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -60,6 +60,9 @@ CAMLMKTOP=ocamlmktop
# Compilation debug flag
CAMLDEBUG=COQDEBUGFLAG
+# User compilation flag
+USERFLAGS=
+
# Compilation profile flag
CAMLTIMEPROF=COQPROFILEFLAG
@@ -101,6 +104,9 @@ COQDOCDIR=COQDOCDIRECTORY
# Win32 systems: true (actually strip is bogus)
STRIP=STRIPCOMMAND
+# Options for fsets (all/basic)
+FSETS=FSETSOPT
+
# Options for reals (all/basic)
REALS=REALSOPT
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 099db808..29ee7f9d 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,7 +6,7 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 5920 2004-07-16 20:01:26Z herbelin $ i*)
+(*i $Id: coq_config.mli 8932 2006-06-09 09:29:03Z notin $ i*)
val local : bool (* local use (no installation) *)
@@ -34,3 +34,4 @@ val theories_dirs : string list
val contrib_dirs : string list
val exec_extension : string (* "" under Unix, ".exe" under MS-windows *)
+val with_geoproof : bool ref (* to (de)activate functions specific to Geoproof with Coqide *)