summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-04-28 14:59:16 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-04-28 14:59:16 +0000
commit3ef7797ef6fc605dfafb32523261fe1b023aeecb (patch)
treead89c6bb57ceee608fcba2bb3435b74e0f57919e /config
parent018ee3b0c2be79eb81b1f65c3f3fa142d24129c8 (diff)
Imported Upstream version 8.0pl3+8.1alphaupstream/8.0pl3+8.1alpha
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template19
-rw-r--r--config/coq_config.mli3
2 files changed, 13 insertions, 9 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index e75b8bd0..9432a884 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -24,26 +24,29 @@ LOCAL=LOCALINSTALLATION
# LIBDIR=path where the Coq library will reside
# MANDIR=path where to install manual pages
# EMACSDIR=path where to put Coq's Emacs mode (coq.el)
-BINDIR='BINDIRDIRECTORY'
-COQLIB='COQLIBDIRECTORY'
-MANDIR='MANDIRDIRECTORY'
-EMACSLIB='EMACSLIBDIRECTORY'
+BINDIR="BINDIRDIRECTORY"
+COQLIB="COQLIBDIRECTORY"
+MANDIR="MANDIRDIRECTORY"
+EMACSLIB="EMACSLIBDIRECTORY"
EMACS=EMACSCOMMAND
# Path to Coq distribution
-COQTOP='COQTOPDIRECTORY'
+COQTOP=COQTOPDIRECTORY
VERSION=COQVERSION
# Directory containing Camlp4 binaries. Can be empty if camlp4 is in the PATH
-CAMLP4BIN='CAMLP4BINDIRECTORY'
+CAMLP4BIN=CAMLP4BINDIRECTORY
# Ocaml version number
CAMLVERSION=CAMLTAG
+# Ocaml .h directory
+CAMLHLIB=CAMLLIBDIRECTORY/caml
+
# Camlp4 library directory (avoid CAMLP4LIB used on Windows)
CAMLP4O=CAMLP4TOOL
CAMLP4COMPAT=CAMLP4COMPATFLAGS
-MYCAMLP4LIB='CAMLP4LIBDIRECTORY'
+MYCAMLP4LIB=CAMLP4LIBDIRECTORY
# Objective-Caml compile command
OCAMLC=BYTECAMLC
@@ -87,7 +90,7 @@ EXE=EXECUTEEXTENSION
MKDIR=mkdir -p
# where to put the coqdoc.sty style file
-COQDOCDIR='COQDOCDIRECTORY'
+COQDOCDIR=COQDOCDIRECTORY
# command to update TeX' kpathsea database
#MKTEXLSR=MKTEXLSRCOMMAND
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 4b780b1f..099db808 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,7 +6,7 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli,v 1.9.16.2 2006/01/10 17:06:23 barras Exp $ i*)
+(*i $Id: coq_config.mli 5920 2004-07-16 20:01:26Z herbelin $ i*)
val local : bool (* local use (no installation) *)
@@ -26,6 +26,7 @@ val osdeplibs : string (* OS dependant link options for ocamlc *)
(* val defined : string list (* options for lib/ocamlpp *) *)
val version : string (* version number of Coq *)
+val versionsi : string (* version number of Coq\_SearchIsos *)
val date : string (* release date *)
val compile_date : string (* compile date *)