summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-01-19 22:34:29 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-01-19 22:34:29 +0000
commit018ee3b0c2be79eb81b1f65c3f3fa142d24129c8 (patch)
treefbb91e2f74c73bb867ab62c58f248a704bbe6dec /config
parent6497f27021fec4e01f2182014f2bb1989b4707f9 (diff)
Imported Upstream version 8.0pl3upstream/8.0pl3
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template17
-rw-r--r--config/coq_config.mli3
2 files changed, 10 insertions, 10 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index cd49db89..e75b8bd0 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -24,25 +24,26 @@ LOCAL=LOCALINSTALLATION
# LIBDIR=path where the Coq library will reside
# MANDIR=path where to install manual pages
# EMACSDIR=path where to put Coq's Emacs mode (coq.el)
-BINDIR="BINDIRDIRECTORY"
-COQLIB="COQLIBDIRECTORY"
-MANDIR="MANDIRDIRECTORY"
-EMACSLIB="EMACSLIBDIRECTORY"
+BINDIR='BINDIRDIRECTORY'
+COQLIB='COQLIBDIRECTORY'
+MANDIR='MANDIRDIRECTORY'
+EMACSLIB='EMACSLIBDIRECTORY'
EMACS=EMACSCOMMAND
# Path to Coq distribution
-COQTOP=COQTOPDIRECTORY
+COQTOP='COQTOPDIRECTORY'
VERSION=COQVERSION
# Directory containing Camlp4 binaries. Can be empty if camlp4 is in the PATH
-CAMLP4BIN=CAMLP4BINDIRECTORY
+CAMLP4BIN='CAMLP4BINDIRECTORY'
# Ocaml version number
CAMLVERSION=CAMLTAG
# Camlp4 library directory (avoid CAMLP4LIB used on Windows)
CAMLP4O=CAMLP4TOOL
-MYCAMLP4LIB=CAMLP4LIBDIRECTORY
+CAMLP4COMPAT=CAMLP4COMPATFLAGS
+MYCAMLP4LIB='CAMLP4LIBDIRECTORY'
# Objective-Caml compile command
OCAMLC=BYTECAMLC
@@ -86,7 +87,7 @@ EXE=EXECUTEEXTENSION
MKDIR=mkdir -p
# where to put the coqdoc.sty style file
-COQDOCDIR=COQDOCDIRECTORY
+COQDOCDIR='COQDOCDIRECTORY'
# command to update TeX' kpathsea database
#MKTEXLSR=MKTEXLSRCOMMAND
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 1d88358a..4b780b1f 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,7 +6,7 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli,v 1.9.16.1 2004/07/16 19:29:58 herbelin Exp $ i*)
+(*i $Id: coq_config.mli,v 1.9.16.2 2006/01/10 17:06:23 barras Exp $ i*)
val local : bool (* local use (no installation) *)
@@ -26,7 +26,6 @@ val osdeplibs : string (* OS dependant link options for ocamlc *)
(* val defined : string list (* options for lib/ocamlpp *) *)
val version : string (* version number of Coq *)
-val versionsi : string (* version number of Coq\_SearchIsos *)
val date : string (* release date *)
val compile_date : string (* compile date *)