summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-02-01 00:54:40 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2009-02-01 00:54:40 +0100
commitcfbfe13f5b515ae2e3c6cdd97e2ccee03bc26e56 (patch)
treeb7832bd5d412a5a5d69cb36ae2ded62c71124c22 /config
parent113b703a695acbe31ac6dd6a8c4aa94f6fda7545 (diff)
Imported Upstream version 8.2~rc2+dfsgupstream/8.2.rc2+dfsg
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template5
-rw-r--r--config/coq_config.mli12
2 files changed, 10 insertions, 7 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index e0e7bf0b..35e2a2d7 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -49,7 +49,7 @@ CAMLP4BIN="CAMLP4BINDIRECTORY"
CAMLVERSION=CAMLTAG
# Ocaml .h directory
-CAMLHLIB="CAMLLIBDIRECTORY"/caml
+CAMLHLIB="CAMLLIBDIRECTORY"
# Camlp4 library directory (avoid CAMLP4LIB used on Windows)
CAMLP4O=CAMLP4TOOL
@@ -96,6 +96,7 @@ BEST=BESTCOMPILER
# Your architecture
# Can be obtain by UNIX command arch
ARCH=ARCHITECTURE
+HASNATDYNLINK=HASNATIVEDYNLINK
# Your C compiler and co
CC="CCEXEC"
@@ -113,6 +114,7 @@ OSDEPLIBS=OSDEPENDENTLIBS
# Unix systems:
# Win32 systems : .exe
EXE=EXECUTEEXTENSION
+DLLEXT=DLLEXTENSION
# the command MKDIR (try to replace it with mkdirhier if you have problems)
MKDIR=mkdir -p
@@ -151,4 +153,3 @@ WITHDOC=WITHDOCOPT
# make or sed are bogus and believe lines not terminating by a return
# are inexistent
-
diff --git a/config/coq_config.mli b/config/coq_config.mli
index af943509..14595fa5 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,19 +6,18 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 11380 2008-09-07 12:27:27Z glondu $ i*)
+(*i $Id: coq_config.mli 11858 2009-01-26 13:27:23Z notin $ i*)
val local : bool (* local use (no installation) *)
-val bindir : string (* where the binaries are installed *)
val coqlib : string (* where the std library is installed *)
+val coqsrc : string (* where are the sources *)
-val coqtop : string (* where are the sources *)
-
-val camldir : string (* base directory of OCaml binaries *)
+val camlbin : string (* base directory of OCaml binaries *)
val camllib : string (* for Dynlink *)
val camlp4 : string (* exact name of camlp4: either "camlp4" ou "camlp5" *)
+val camlp4bin : string (* base directory for Camlp4/5 binaries *)
val camlp4lib : string (* where is the library of Camlp4 *)
val best : string (* byte/opt *)
@@ -30,6 +29,7 @@ val coqrunbyteflags : string (* -custom/-dllib -lcoqrun *)
(* val defined : string list (* options for lib/ocamlpp *) *)
val version : string (* version number of Coq *)
+val caml_version : string (* OCaml version used to compile Coq *)
val date : string (* release date *)
val compile_date : string (* compile date *)
val vo_magic_number : int
@@ -44,3 +44,5 @@ val with_geoproof : bool ref (* to (de)activate functions specific to Geoproof w
val browser : string
(** default web browser to use, may be overriden by environment
variable COQREMOTEBROWSER *)
+
+val has_natdynlink : bool