summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2008-09-08 00:15:04 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2008-09-08 00:15:04 +0200
commit113b703a695acbe31ac6dd6a8c4aa94f6fda7545 (patch)
treec260a140410c796f113584a2f7e6b9b7f6e00aa5 /config
parent870075f34dd9fa5792bfbf413afd3b96f17e76a0 (diff)
Imported Upstream version 8.2~beta4.svn20080907+dfsgupstream/8.2.beta4.svn20080907+dfsg
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template7
-rw-r--r--config/coq_config.mli4
2 files changed, 9 insertions, 2 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index fc8af173..e0e7bf0b 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -21,6 +21,10 @@ COQ_CONFIGURED=yes
# Local use (no installation)
LOCAL=LOCALINSTALLATION
+# Bytecode link flags for VM ("-custom" or "-dllib -lcoqrun")
+COQRUNBYTEFLAGS=XCOQRUNBYTEFLAGS
+BUILDLDPATH=
+
# Paths for true installation
# BINDIR=path where coqtop, coqc, coqmktop, coq-tex, coqdep, gallina and
# do_Makefile will reside
@@ -28,7 +32,7 @@ LOCAL=LOCALINSTALLATION
# MANDIR=path where to install manual pages
# EMACSDIR=path where to put Coq's Emacs mode (coq.el)
BINDIR="BINDIRDIRECTORY"
-COQLIB="COQLIBDIRECTORY"
+COQLIBINSTALL="COQLIBDIRECTORY"
MANDIR="MANDIRDIRECTORY"
DOCDIR="DOCDIRDIRECTORY"
EMACSLIB="EMACSLIBDIRECTORY"
@@ -58,6 +62,7 @@ COQIDEINCLUDES=LABLGTKINCLUDES
# Objective-Caml compile command
OCAML="OCAMLEXEC"
OCAMLC="BYTECAMLC"
+OCAMLMKLIB="OCAMLMKLIBEXEC"
OCAMLOPT="NATIVECAMLC"
OCAMLDEP="OCAMLDEPEXEC"
OCAMLDOC="OCAMLDOCEXEC"
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 3898a0f3..af943509 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,7 +6,7 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 11313 2008-08-07 11:15:03Z barras $ i*)
+(*i $Id: coq_config.mli 11380 2008-09-07 12:27:27Z glondu $ i*)
val local : bool (* local use (no installation) *)
@@ -24,6 +24,8 @@ val camlp4lib : string (* where is the library of Camlp4 *)
val best : string (* byte/opt *)
val arch : string (* architecture *)
val osdeplibs : string (* OS dependant link options for ocamlc *)
+val coqrunbyteflags : string (* -custom/-dllib -lcoqrun *)
+
(* val defined : string list (* options for lib/ocamlpp *) *)