summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2012-01-12 16:02:20 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2012-01-12 16:02:20 +0100
commit97fefe1fcca363a1317e066e7f4b99b9c1e9987b (patch)
tree97ec6b7d831cc5fb66328b0c63a11db1cbb2f158 /config
parent300293c119981054c95182a90c829058530a6b6f (diff)
Imported Upstream version 8.4~betaupstream/8.4_beta
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template11
-rw-r--r--config/coq_config.mli11
2 files changed, 12 insertions, 10 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index 8864f52d..91b12cb4 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -34,6 +34,8 @@ BUILDLDPATH=
# EMACSDIR=path where to put Coq's Emacs mode (coq.el)
BINDIR="BINDIRDIRECTORY"
COQLIBINSTALL="COQLIBDIRECTORY"
+CONFIGDIR="CONFIGDIRDIRECTORY"
+DATADIR="DATADIRDIRECTORY"
MANDIR="MANDIRDIRECTORY"
DOCDIR="DOCDIRDIRECTORY"
EMACSLIB="EMACSLIBDIRECTORY"
@@ -56,6 +58,7 @@ CAMLLIB="CAMLLIBDIRECTORY"
CAMLHLIB="CAMLLIBDIRECTORY"
# Camlp4 library directory (avoid CAMLP4LIB used on Windows)
+CAMLP4=CAMLP4VARIANT
CAMLP4O=CAMLP4TOOL
CAMLP4COMPAT=CAMLP4COMPATFLAGS
MYCAMLP4LIB="CAMLP4LIBDIRECTORY"
@@ -137,15 +140,13 @@ STRIP=STRIPCOMMAND
# CoqIde (no/byte/opt)
HASCOQIDE=COQIDEOPT
+IDEOPTFLAGS=IDEARCHFLAGS
+IDEOPTDEPS=IDEARCHFILE
+IDEOPTINT=IDEARCHDEF
# Defining REVISION
CHECKEDOUT=CHECKEDOUTSOURCETREE
-# Defining options to generate dependencies graphs
-DOT=dot
-DOTOPTS=-Tps
-ODOCDOTOPTS=-dot -dot-reduce
-
# Option to control compilation and installation of the documentation
WITHDOC=WITHDOCOPT
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 6845df7d..35446072 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -1,17 +1,17 @@
(************************************************************************)
(* v * The Coq Proof Assistant / The Coq Development Team *)
-(* <O___,, * INRIA - CNRS - LIX - LRI - PPS - Copyright 1999-2011 *)
+(* <O___,, * INRIA - CNRS - LIX - LRI - PPS - Copyright 1999-2010 *)
(* \VV/ **************************************************************)
(* // * This file is distributed under the terms of the *)
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 14641 2011-11-06 11:59:10Z herbelin $ i*)
-
val local : bool (* local use (no installation) *)
-val coqlib : string (* where the std library is installed *)
-val coqsrc : string (* where are the sources *)
+val coqlib : string option (* where the std library is installed *)
+val configdir : string option (* where configuration files are installed *)
+val datadir : string option (* where extra data files are installed *)
+val docdir : string (* where the doc is installed *)
val ocaml : string (* names of ocaml binaries *)
val ocamlc : string
@@ -60,6 +60,7 @@ val browser : string
variable COQREMOTEBROWSER *)
val has_coqide : string
+val gtk_platform : [`QUARTZ | `WIN32 | `X11]
val has_natdynlink : bool
val natdynlinkflag : string (* special cases of natdynlink (e.g. MacOS 10.5) *)