summaryrefslogtreecommitdiff
path: root/config/Makefile.template
diff options
context:
space:
mode:
Diffstat (limited to 'config/Makefile.template')
-rw-r--r--config/Makefile.template11
1 files changed, 6 insertions, 5 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index 8864f52d..91b12cb4 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -34,6 +34,8 @@ BUILDLDPATH=
# EMACSDIR=path where to put Coq's Emacs mode (coq.el)
BINDIR="BINDIRDIRECTORY"
COQLIBINSTALL="COQLIBDIRECTORY"
+CONFIGDIR="CONFIGDIRDIRECTORY"
+DATADIR="DATADIRDIRECTORY"
MANDIR="MANDIRDIRECTORY"
DOCDIR="DOCDIRDIRECTORY"
EMACSLIB="EMACSLIBDIRECTORY"
@@ -56,6 +58,7 @@ CAMLLIB="CAMLLIBDIRECTORY"
CAMLHLIB="CAMLLIBDIRECTORY"
# Camlp4 library directory (avoid CAMLP4LIB used on Windows)
+CAMLP4=CAMLP4VARIANT
CAMLP4O=CAMLP4TOOL
CAMLP4COMPAT=CAMLP4COMPATFLAGS
MYCAMLP4LIB="CAMLP4LIBDIRECTORY"
@@ -137,15 +140,13 @@ STRIP=STRIPCOMMAND
# CoqIde (no/byte/opt)
HASCOQIDE=COQIDEOPT
+IDEOPTFLAGS=IDEARCHFLAGS
+IDEOPTDEPS=IDEARCHFILE
+IDEOPTINT=IDEARCHDEF
# Defining REVISION
CHECKEDOUT=CHECKEDOUTSOURCETREE
-# Defining options to generate dependencies graphs
-DOT=dot
-DOTOPTS=-Tps
-ODOCDOTOPTS=-dot -dot-reduce
-
# Option to control compilation and installation of the documentation
WITHDOC=WITHDOCOPT