summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-11-26 19:15:53 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-11-26 19:15:53 +0000
commitdbc1489e1d5f070da297f9ff6f4201f63f924a11 (patch)
treedc0720e4af278c4b7a1a125bc55ff0126979fcb6
parentb9343b970c40160fdd0329590a03fdec097de54c (diff)
Added next-ia64.dpatch to fix the FTBFS on ia64.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/next-ia64.dpatch23
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f3fec6fd..09e2bc3f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+coq (8.1~gamma-3) UNRELEASED; urgency=low
+
+ * Added next-ia64.dpatch to fix the FTBFS on ia64.
+
+ -- Samuel Mimram <smimram@debian.org> Sun, 26 Nov 2006 18:45:33 +0000
+
coq (8.1~gamma-2) experimental; urgency=low
* Added no-complexity-test.dpatch to skip complexity checks (thanks Julien
diff --git a/debian/patches/00list b/debian/patches/00list
index 9e577fa3..aa31c567 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -3,3 +3,4 @@ browser
makefile
system
no-complexity-test
+next-ia64
diff --git a/debian/patches/next-ia64.dpatch b/debian/patches/next-ia64.dpatch
new file mode 100755
index 00000000..e9f7635f
--- /dev/null
+++ b/debian/patches/next-ia64.dpatch
@@ -0,0 +1,23 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## next-ia64.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Disable not-really-needed ia64 cast which broke with gcc 4.0.
+
+@DPATCH@
+diff -urNad coq-8.1~gamma~/kernel/byterun/coq_interp.c coq-8.1~gamma/kernel/byterun/coq_interp.c
+--- coq-8.1~gamma~/kernel/byterun/coq_interp.c 2006-10-27 13:29:22.000000000 +0000
++++ coq-8.1~gamma/kernel/byterun/coq_interp.c 2006-11-26 18:37:23.000000000 +0000
+@@ -44,11 +44,7 @@
+ # ifdef DEBUG
+ # define Next goto next_instr
+ # else
+-# ifdef __ia64__
+-# define Next goto *(void *)(coq_jumptbl_base + *((uint32 *) pc)++)
+-# else
+-# define Next goto *(void *)(coq_jumptbl_base + *pc++)
+-# endif
++# define Next goto *(void *)(coq_jumptbl_base + *pc++)
+ # endif
+ #else
+ # define Instruct(name) case name: