summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-11-23 14:28:36 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-11-23 14:28:36 +0000
commitb9343b970c40160fdd0329590a03fdec097de54c (patch)
treeb272880599428e1c22e577dc3eeff659fe0003fc
parent94594cf938e4523e60c2a750d56e5a4ab6ca5a42 (diff)
Skip complexity checks.debian/8.1.gamma-2
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/no-complexity-test.dpatch21
3 files changed, 29 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 01c212df..f3fec6fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+coq (8.1~gamma-2) experimental; urgency=low
+
+ * Added no-complexity-test.dpatch to skip complexity checks (thanks Julien
+ Cristau), closes: #399919.
+
+ -- Samuel Mimram <smimram@debian.org> Thu, 23 Nov 2006 14:27:15 +0000
+
coq (8.1~gamma-1) experimental; urgency=low
* New upstream release.
diff --git a/debian/patches/00list b/debian/patches/00list
index 5e873f10..9e577fa3 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -2,3 +2,4 @@ coqdoc_stdlib
browser
makefile
system
+no-complexity-test
diff --git a/debian/patches/no-complexity-test.dpatch b/debian/patches/no-complexity-test.dpatch
new file mode 100644
index 00000000..bf89f1f7
--- /dev/null
+++ b/debian/patches/no-complexity-test.dpatch
@@ -0,0 +1,21 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## no-complexity-test.dpatch by Julien Cristau <julien.cristau@ens-lyon.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Don't run complexity tests, they are far too fragile.
+
+@DPATCH@
+diff -urNad coq-8.1gamma~/test-suite/check coq-8.1gamma/test-suite/check
+--- coq-8.1gamma~/test-suite/check 2006-11-03 14:07:27.000000000 +0100
++++ coq-8.1gamma/test-suite/check 2006-11-23 15:19:49.000000000 +0100
+@@ -145,8 +145,8 @@
+ test_parser parser
+ echo "Interactive tests"
+ test_interactive interactive
+-echo "Complexity tests"
+-test_complexity complexity
++echo "Skipping complexity tests"
++#test_complexity complexity
+ echo "Module tests"
+ $coqtop -compile modules/Nat
+ $coqtop -compile modules/plik