summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-11-21 21:38:49 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-11-21 21:38:49 +0000
commit94594cf938e4523e60c2a750d56e5a4ab6ca5a42 (patch)
treec59411813c41fb7396d679558f39a4770eec1b15
parent70b9be8acc1d1ada178a95c1cd4013506e9d0d1b (diff)
New upstream release.debian/8.1.gamma-1
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list2
-rwxr-xr-xdebian/patches/assert.dpatch19
-rwxr-xr-xdebian/patches/system.dpatch19
-rwxr-xr-xdebian/rules2
5 files changed, 26 insertions, 23 deletions
diff --git a/debian/changelog b/debian/changelog
index 60d9af56..01c212df 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,12 @@
-coq (8.0pl3+8.1beta.2-2) UNRELEASED; urgency=low
+coq (8.1~gamma-1) experimental; urgency=low
+ * New upstream release.
* Made the package binNMU-safe.
* Minor improvements of the coqide.desktop file, closes: #383310.
+ * Added system.dpatch to avoid erroneous interpretation of ~.
+ * Removed assert.dpatch, integrated upstream.
- -- Samuel Mimram <smimram@debian.org> Sat, 11 Nov 2006 12:18:59 +0100
+ -- Samuel Mimram <smimram@debian.org> Tue, 21 Nov 2006 13:33:55 +0000
coq (8.0pl3+8.1beta.2-1) experimental; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index 826a242c..5e873f10 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,4 +1,4 @@
coqdoc_stdlib
browser
makefile
-assert
+system
diff --git a/debian/patches/assert.dpatch b/debian/patches/assert.dpatch
deleted file mode 100755
index 16a62f5f..00000000
--- a/debian/patches/assert.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## assert.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Check assertions in native mode too.
-
-@DPATCH@
-diff -urNad coq-8.0pl3+8.1beta.2~/Makefile coq-8.0pl3+8.1beta.2/Makefile
---- coq-8.0pl3+8.1beta.2~/Makefile 2006-06-25 22:17:49.000000000 +0000
-+++ coq-8.0pl3+8.1beta.2/Makefile 2006-07-13 16:27:10.000000000 +0000
-@@ -74,7 +74,7 @@
- MLINCLUDES=$(LOCALINCLUDES) -I $(MYCAMLP4LIB)
-
- BYTEFLAGS=$(MLINCLUDES) $(CAMLDEBUG) $(USERFLAGS)
--OPTFLAGS=$(MLINCLUDES) $(CAMLTIMEPROF) $(USERFLAGS) -noassert
-+OPTFLAGS=$(MLINCLUDES) $(CAMLTIMEPROF) $(USERFLAGS)
- OCAMLDEP=ocamldep
- DEPFLAGS=$(LOCALINCLUDES)
-
diff --git a/debian/patches/system.dpatch b/debian/patches/system.dpatch
new file mode 100755
index 00000000..ab8bded8
--- /dev/null
+++ b/debian/patches/system.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## system.dpatch by Hugo Herbelin <hugo.herbelin@inria.fr>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fix interpretation of ~.
+
+@DPATCH@
+diff -urNad coq-8.1~gamma~/lib/system.ml coq-8.1~gamma/lib/system.ml
+--- coq-8.1~gamma~/lib/system.ml 2006-05-30 16:37:04.000000000 +0000
++++ coq-8.1~gamma/lib/system.ml 2006-11-21 21:12:08.000000000 +0000
+@@ -43,7 +43,7 @@
+ let v = safe_getenv (String.sub s (i+1) (n-i-1)) in
+ let s = (String.sub s 0 i)^v^(String.sub s n (l-n)) in
+ expand_macros s (i + String.length v)
+- | '~' ->
++ | '~' when i = 0 ->
+ let n = expand_atom s (i+1) in
+ let v =
+ if n=i+1 then home
diff --git a/debian/rules b/debian/rules
index 57444fb7..6bdb7e65 100755
--- a/debian/rules
+++ b/debian/rules
@@ -54,7 +54,7 @@ clean: unpatch
-$(MAKE) clean
-$(MAKE) archclean
- rm -f bin/parser.opt
+ rm -f bin/*
rm -f tools/coqdoc/*.cm[oi]
rm -f config/coq_config.ml config/Makefile test-suite/check.log
rm -f dev/ocamldebug-v7