summaryrefslogtreecommitdiff
path: root/test/cminor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/cminor/Makefile')
-rw-r--r--test/cminor/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/test/cminor/Makefile b/test/cminor/Makefile
index e498841..29ebf69 100644
--- a/test/cminor/Makefile
+++ b/test/cminor/Makefile
@@ -5,7 +5,8 @@ CFLAGS=-arch ppc -g
ASFLAGS=-arch ppc
VPATH=../harness ../lib
-PROGS=fib integr qsort fft sha1 aes almabench manyargs lists stopcopy
+PROGS=fib integr qsort fft sha1 aes almabench manyargs lists \
+ stopcopy marksweep
all_s: $(PROGS:%=%.s)
@@ -63,6 +64,11 @@ stopcopy: stopcopy.o maingc.o
clean::
rm -f stopcopy
+marksweep: marksweep.o maingc.o marksweepcheck.o
+ $(CC) $(CFLAGS) -o marksweep marksweep.o maingc.o marksweepcheck.o
+clean::
+ rm -f stopcopy
+
.SUFFIXES:
.SUFFIXES: .cmp .cm .s .o .c .S
@@ -83,5 +89,7 @@ clean::
.S.o:
$(AS) $(ASFLAGS) -o $*.o $<
+.SECONDARY: $(PROGS:%=%.s)
+
clean::
rm -f *.s *.o *~