summaryrefslogtreecommitdiff
path: root/test/cminor/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2006-10-27 12:16:54 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2006-10-27 12:16:54 +0000
commit7a3338431e5f09a90bfda16350202f5c7780d110 (patch)
treebe0e175c0ba21b3401cc227854efe7e60fc0b558 /test/cminor/Makefile
parentca285074159abb65a815db5c08284becaa297df0 (diff)
Ajout test mark&sweep GC
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@134 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/cminor/Makefile')
-rw-r--r--test/cminor/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/test/cminor/Makefile b/test/cminor/Makefile
index e498841..29ebf69 100644
--- a/test/cminor/Makefile
+++ b/test/cminor/Makefile
@@ -5,7 +5,8 @@ CFLAGS=-arch ppc -g
ASFLAGS=-arch ppc
VPATH=../harness ../lib
-PROGS=fib integr qsort fft sha1 aes almabench manyargs lists stopcopy
+PROGS=fib integr qsort fft sha1 aes almabench manyargs lists \
+ stopcopy marksweep
all_s: $(PROGS:%=%.s)
@@ -63,6 +64,11 @@ stopcopy: stopcopy.o maingc.o
clean::
rm -f stopcopy
+marksweep: marksweep.o maingc.o marksweepcheck.o
+ $(CC) $(CFLAGS) -o marksweep marksweep.o maingc.o marksweepcheck.o
+clean::
+ rm -f stopcopy
+
.SUFFIXES:
.SUFFIXES: .cmp .cm .s .o .c .S
@@ -83,5 +89,7 @@ clean::
.S.o:
$(AS) $(ASFLAGS) -o $*.o $<
+.SECONDARY: $(PROGS:%=%.s)
+
clean::
rm -f *.s *.o *~