summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 3f4ea40..3ee10c9 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -9,10 +9,12 @@ LIBS=
TIME=xtime -o /dev/null -mintime 1.0 # Xavier's hack
#TIME=time >/dev/null # Otherwise
-PROGS=fib integr qsort fft sha1 aes almabench lists \
+BENCHS=fib integr qsort fft sha1 aes almabench lists \
binarytrees fannkuch knucleotide mandelbrot nbody \
nsieve nsievebits spectral
+PROGS=$(BENCHS) initializers
+
all_s: $(PROGS:%=%.s)
all: $(PROGS:%=%.compcert)
@@ -45,12 +47,12 @@ test_gcc:
done
time_gcc:
- @for i in $(PROGS); do \
+ @for i in $(BENCHS); do \
echo -n "$$i: "; $(TIME) ./$$i.gcc; \
done
time_compcert:
- @for i in $(PROGS); do \
+ @for i in $(BENCHS); do \
echo -n "$$i: "; $(TIME) ./$$i.compcert; \
done